Unable to submit changes

I am running FPBX 12 with latest version.

For some reason, when I submit changes for an extension, the page times out, and changes are not kept. I tried to get around this but changing my extension info via Bulk Extensions. When I click on Export, I get the same thing.

Any ideas?

This is what is comming back: (actual domain changed to someplace.com)

The someplace.com page isn’t working

someplace.com didn’t send any data.

Plz check you host name (/etc/hosts) and be sure about your DNS name.

Log in on the console as root. I suggest that you run the command:

grep -l someplace.com `find /etc’

That will give you the list of names for all of the files that contain the string “someplace.com”. The hosts file is likely to have it, but there are lots of other places that will actually “set” the hostname to that.

You can also run the command “hostname” without any arguments to find out what you computer thinks it is called.

I took a look this morning. There was a discrepancy and through the Freepbx System Admin I updated the hostname. It rewrote the Hosts file and probably others, but didn’t notice. I thought it was fixed, but now I check from my office (it’s a remote site) and doesn’t work from here. Grrr.

It does occur to me, though, that I may have to restart the box. Additionally, I tried using the IP address instead, same result.

does your hostname actually resolve to an ip address. ping someplace.com from your remote office and see what you get.

also check your dns servers - you can do that from the GUI sysadmin - it should show as the first entry and then other dns ip’s that you have set up

The someplace.com DOES resolve. I CAN access the web interface, and browse around. What doesn’t work is when I click on a button to submit info. At that point it jams.

In hopes of side- stepping the issue, I tried using the IP address. No change.

what are you using for dns ?

Turns out that I had to add as the first line in the DNS settings of FreePBX. Duh.