Unable to see my X100P's in FreePBX

I just installed FreePBX on my home server and I have two X100P boards in the computer (I have been using this computer and these cards for years with earlier versions of FreePBX), but they don’t show up in the DAHDI settings in FreePBX nor in the CLI for dahdi show status or dahdi show channels - however the dahdi_scan detects them fine:

description=Wildcard X100P Board 1
devicetype=Wildcard X100P
location=PCI Bus 03 Slot 02
description=Wildcard X100P Board 2
devicetype=Wildcard X100P
location=PCI Bus 03 Slot 03

Is there something else I need to be doing to get the system to recognize my cards? I know that there’s a lot of bias about the X100P’s but they have worked well for me for a long time. I have a 4 port analog Digium card but just don’t have it handy right now (I have to extract it from another old PBX I used to use) so i can resort to that if I must but it seems this should work if dahdi_scan detects them.

I am running the latest build of FreePBX and Asterisk 13 (just downloaded the distro this evening).

One other note, neither card is plugged into a phone line at the moment, I’m bench installing this right now.

I think everyone with experience here will say just stop trying to make them work, the are terminally FU’ed so few will waste time helping you, (it’s called dorodango), spend the time to dig up the Digium and your problems will almost certainly go away.

I appreciate the response but it bugs me that they can be seen but they aren’t coming into the config. I have the digium card in my back pocket, and will likely use it, but I’m curious.

I would suggest you either do it the old fashioned “zaptel converted to dahdi” (with all the necessary IRQ fixes et al added as necessary) manual way or if that bugs you, file a bug with the publisher of that module :wink:

Thank you for that tip, it actually helped me :). Prior to going with Asterisk 13 I always used Zaptel, I didn’t realize Dahdi was so close to Zaptel in how it was used, once I read up a little bit on it I saw that there is a dahdi_genconf that works like genzaptelconf, once I ran this everything starts showing up in FBPX.

I’m sure I’ll still use the Digium card - it’s just sitting around collecting dust anyway - but I wanted to just see if I could get this to work. Truth be told I’ve wanted to put that Digium card in my home PBX for a while just never got around to it.

Anyone else stumbling upon this thread with similar issues, if you used Zaptel prior there’s a good article I found. It covers upgrading from Zaptel which is unimportant with the latest FPBX distro but there is a section in that article that answered my question:

Now when upgrading from Zaptel, you need to modify your configuration files to enable your hardware in DAHDI. Most notably:

/etc/zaptel.conf is now /etc/dahdi/system.conf
The only real change here is new option ‘echocanceller’. This option allows you to configure software echocancellation on a channel by channel basis. If the echocanceller line is not specified here, then software echocancellation cannot function.

To configure the default echo cancellers, use the format: echocanceller=,<channel(s)>
So to use MG2 on the first eight channels: echocanceller=mg2,1-8

/etc/sysconfig/zaptel or /etc/default/zaptel are now replaced by /etc/dahdi/init.conf

/etc/asterisk/zapata.conf is now /etc/asterisk/chan_dahdi.conf
If necessary you should be able to simply rename an existing zapata.conf file to chan_dahdi.conf and get the system up and running again with DAHDI.

All zaptel userspace tools have also been replaced with a DAHDI counterpart. All DAHDI tools are prefixed with ‘dahdi_’ now (with the exception of the HPEC tool). For example:

zttool is now dahdi_tool
ztcfg is now dahdi_cfg
ztmonitor is now dahdi_monitor
genzaptelconf is now dahdi_genconf
zaphpec_enable is now dahdihpec_enable

You can see the entire article at http://kb.digium.com/articles/Installation/Upgrade-from-Zaptel-to-DAHDI

In the terminal , run this command

pci:0000:03:01.0 wctdm24xxp+ d161:8005 Wildcard TDM410P

You are incorrect.

My x100p clone cards have worked every time they were installed and configure correctly. The issue is apparently unique to FreePBX. they work in Elastix and Vanilla Asterisk just fine. There is a detection utility you need to run . I do not remember the name at present. (if cards are not detected you need to run this utility that FreePBX advises you against using)

They also worked and were detected in the last FreePBX (SCMZ 6.6 Asterisk 11) that I installed 2 days ago. I did install FreePBX with the FXO card already installed.

Dicko if you have not run them nor use them stop trying to be “the expert”, what a dicko

Yea, I had mentioned that a couple posts back, it’s dahdi_genconf, replaced genzaptelconf. That “fixed” my problem before I reinstalled FreePBX.

I’ve never had a problem until then either, but I do have them 100% working now, I just honestly needed to reinstall FreePBX as the first install was from a USB drive and had some issues. I’ve had them working for nearly a week on the latest version and am happy with them just as I was with my previous version of FreePBX.

Everyone has their opinions, I don’t hold it against anyone for “hating on the X100P”, but frankly for a home PBX it’s a good cheap option.