Unable to retrieve PJSIP transport 'udp,tcp,ws,wss'

After allowing Anonymous Inbound SIP Calls, FreePBX creates the anonymous endpoint, but sets the transport to “udp,tcp,ws,wss”, the problem is that i only have one transport configured with the name “”, and when i try to receive calls made to my number the calls get terminated - I have checked with the Sip provider and they gave me error 500 as it an internal error.
so ran the monitor on the freePBX and the error came up as the following:

ERROR[16258]: res_pjsip.c:3023 ast_sip_set_tpselector_from_transport_name: Unable to retrieve PJSIP transport ‘udp,tcp,ws,wss’

Has anyone found any solution for this issue?

No. Do not do that. Turn that off RIGHT NOW. Disable that setting. Run away. “Danger, Will Robinson.” No.
Turn off “Anonymous Inbound Calls”. Do not allow that to be turned on. Disable it. Elide that option from your current operation.

You need to set up your inbound calling correctly - do not use Anonymous Inbound SIP under any circumstances.

Let us know when you get that turned off and what is happening after that. We will help you once you turn off Anonymous calling.

1 Like

OK thanks for the reply.

I have disabled the Allow Anonymous inbound Sip Calls, but now can you direct me to how to set up my system to be able to receive Calls?

You haven’t even mentioned if you are using Asterisk, so it’s going to be a challenge.

What version of the PBX are you using?
Do you have an Internet Telephone Service Provider?
Are you trying to connect your PBX to another PBX, or the Internet?

Tell us what you are trying to do and we can help you.

Hi Dave
I am using FreePBX 14 Asterisk 13 the latest version and trying to connect my PBX to the Voip Provider

Your ITSP (VOIP Provider) should provide you with the “USER” and “PEER” configuration example so that you can set up a trunk to your provider. Once the trunk is set up, you need to establish inbound and outbound routes to your ITSP.

So, check with your provider and see what trunk configuration you need, set that up, and let us know if you are still having issues.

OK, this is wrong. First, he’s using PJSIP so there is no USER/PEER sections because that’s a Chan_SIP thing. Second, providers that offer up sample configs means that someone there actually tested/knew Asterisk in order to create that sample config. That’s how all sample configs get made for different IP-PBXes by providers/carriers. Someone tests them with their service so they know what settings are needed. In some cases providers just may go “Here’s your settings, how you program your PBX with them is on you”. Never assume a provider is going to whip out an Asterisk config sample, even more so, don’t think they’re going to whip out a PJSIP config since most the providers still use Asterisk 1.4/1.6 samples.

@mvahedi, @cynjut is correct on you shouldn’t have Allow Anonymous Inbound SIP Calls. It will only work for one thing if you have Allow SIP Guests, so you should make sure THAT is off. Allow Anonymous is a dialplan thing, not an Asterisk setting. It is so when unknown (like SIP Guests) hit the PBX and it forces them into a dialplan context that lets you see more information about them. So if you have Allow SIP Guests set to NO than the Anonymous setting has no effect, even when enabled.

Can you show a screenshot of your PJSIP configuration for the trunk or the Chan_SIP configuration, as you really haven’t stated what SIP driver you’re trying to us. Black out any secrets/passwords.


I have this issue with “res_pjsip.c: Unable to retrieve PJSIP transport ‘udp,tcp,ws,wss’” error is the Asterisk log. I installed FreePBX 14 some months ago on a VM on a Dell Power Edge and with the help of some excellent YouTubes from CrossTalk Solutions got a number of polycom phones and softphones working well on a handful of extensions on my LAN at our little pacific island tourist attraction. I have a Australian DID number with DIDww.com set up. Traffic from DIDww arrives at my router and get sent to the FreePBX system. But I cannot receive calls (nor make them). I have read the knowledgebase and tutorials (which seem a little out of date to the version I have). But the trunking and in and out routes has me stumped. Any help would be much appreciated.

At this point in the conversation, one would normally send logs of a failed call. That might help us a lot.

Also, inbound calling and outbound calling, are largely unrelated. You can have inbound or outbound working and not have the other - in fact, it’s one of the most common problems we see. The fact that you are having both isn’t surprising but it’s also like two problems (perhaps related).

Show us a log extract of an incoming call that failed - we can tell a lot from that.