Unable to reliably making Sangoma Talk work when there is a physical desktop phone registered

Hi,

I’ve been struggling to make Sangoma Talk work on an extension that also has a physical Sangoma desktop phone (P320) registered.

If the softphone is the only registered device on an extension, it seems to work properly. Use case is somebody is on-calls duty and away from the office (nights/weekends) and has Sangoma Talk configured on his cell phone with the same extension/user than his desktop phone.

If there is an Inbound call, the physical phone always ring but the softphone randomly rings but more often than not, it doesn’t.

If the softphone is the sole registered device, it always seems to work properly.

TIA

1 Like

Added Informations:
FreePBX 16.0.40.7
Asterisk 18.20.2
NAT’ed by a pfSense firewall and ports from https://sangomakb.atlassian.net/wiki/spaces/SS1/pages/31392017/Technical+Details
Are forwarded from clients IP addresses and SangomaCloud address list (I’ve also forwarded RTP and SIP-TLS, not sure if SIP-TLS is need from SangomaCloud…)

Try setting Max Contacts for the extension to 4.

It is already set to 6

Does the Asterisk log show the softphone going unreachable, or registering from varying ports?

I will do further testing to catch the logs. Last time I checked I saw some contacts going unreachable but I thought it was related to wifi-LTE switch.