Unable to register Grandstream ATA as a trunk (outbound calls are affected)

Hi guys,

Cannot figure this out on my own.

I did some reconfigurations for my extensions and call handlings recently and noticed that my ATA adapter with ISP PSTN number no longer works for outgoing call. If I call out from designated IP phone it uses my SIP trunk, which is expected because Outbound routes have other SIP trunks.

Here are the Asterisk logs I observe:

[2022-08-30 12:13:28] WARNING[51836] res_pjsip_registrar.c: AOR ‘’ not found for endpoint ‘spectrum’

[2022-08-30 12:13:51] WARNING[47992] res_pjsip_outbound_registration.c: ‘405’ fatal response received from ‘sip:’ on registration attempt to ‘sip:PSTN #(hidden)@<—this is my grandstream adapter LAN IP:5060’, retrying in ‘30’ seconds

SNGREP screenshot:

Asterisk info for pjsip shows this: spectrum/sip: spectrum Rejected

Can anyone point me please to the direction where I should look at?

Note: I checked Grandstream itself, no settings were altered from the past.

Few things changed:

  • ISP increased the speed, I rebooted modem.
  • On FreePBX, changed some extensions, IVR’s.

Thank you.

The Grandstream is rejecting the registration from the PBX because it doesnt allow it. What model Grandstream is this?

Model looks like a Grandstream HT813

Yes HT813. It worked before.

I understand it worked before but the rejection is from the HT813 with a 405 Method Not Allowed. So the HT813 isn’t allowing the request.

Ok, I rebooted it from GUI, verified my old settings, all seems to be correct…
I can make inbound call with it OK.
When call out it goes to my SIP trunk which is not ideal.

Interestingly pjsip trunk itself is active:

The HT is not a SIP server and will not accept a REGISTER request.

One possibility is that the trunk somehow got changed to have Registration Send; it should be Registration None (if the HT address is statically configured) or Registration Receive (if HT registers to Asterisk).

Or, you might have a config where registration was always failing, but was not actually required for calls. Something else went wrong that is now causing outbound to fail.

Turn on pjsip logger, make a failing call, paste the relevant section of the Asterisk log at pastebin.freepbx.org and post the link here.

Thank you for reply. Are you referring some setting in HT? The unit is configured with static IP.

With Registration None, the IP address of the HT is configured in the trunk as SIP Server, and the IP address of the PBX is configured in the HT (which is told to not register). Each side knows how to find the other.

With Registration Receive, the HT registers to Asterisk, which then learns the HT’s address.

Paste the relevant section of the Asterisk log (with SIP trace) so we can see whether the HT was contacted and how it responded.

Ok, let me re-check settings in HT. I will post logs.

I think you meant registrar, not server. It has to be a server to support outbound calls.

Can you elaborate on this? This logic states that my Bria is a server. It supports outbound calls.

Outbound is itself loose, and I was using the term relative to Asterisk, whereas the subject is using it relative the phone. The Bria is a SIP client (SIP UAC) when you make a call from it, and the a SIP server (SIP UAS) when you receive a call on it. SIP Is defined in a symmetric way, that doesn’t classify boxes as purely client or purely server. RFC 3261 doesn’t talk about phones and PABXes, or even stations and (central) offices. When it uses the term client, it is in relation to a single transaction, and roles can switch even within a call.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.