Unable to provision SNOM phones on freepbx

Hi All,
I have set up a few installs now using FreePBX and all have been great except for my one that i use… …

Now i have downloaded and installed this 4 times on 3 different sets of hardware and keep coming up with the same problem.
Phones will not auto-provision.

Phones: SNOM 320 and SNOM 360
All phones are running frimware 8.4.35 (although have tried on different versions 6.5.20 and 7.3.3)

My steps so far…
Setup new install of FreePBX, setup settings in General Settings, changed AMP password, gone to module admin and updated modules and installed endpoint manager. Created extensions 101 & 102.
Setup DHCP and bind to eth1 (DHCP file below)
Setup in and out routes.
Endpoint Configuration… Enabled SNOM and models 320,360&M3.
Advanced Configuratio … IP Address (Determined for me), Timezone AU/Perth, Timeserver pool.ntp.org … all the rest default.
I go to Device list and set the network to my eth1 network range and search and the handset is found.
Tick the box … assign ext101 and let it use the custom template it creates from mac aadress and tell it to reboot phone.

Nothing happens. If i manually tell the phone to reset then it hangs on checking configuration and i cannot get into it even in the web interface.
IP address is coming out fine from DHCP and if i put phone on another network to get into the web interface it has got the updated settings for http password and reset password so all a little weird.

Any suggestions ??? as i said, i have tried this 4 times now and yet have it working happily in a couple of other places no problem…

dhcpd.conf file

ddns-update-style interim;
ignore client-updates;

subnet netmask {

option routers;
option subnet-mask;
option nis-domain “freepbx.mydomain.local”;
option domain-name “freepbx.mydomain.local”;
option domain-name-servers;
option time-offset 8; #Perth
option ntp-servers;
option tftp-server-name “”;

range dynamic-bootp;
default-lease-time 43200;
max-lease-time 86400;


The above settings came from my trixbox and worked happily there and on other freepbx installs done in the last 2 weeks !!!

Hopefully someone out there has a magic wand that can point me in the right direction. At present all phones are registered, but had to do manually (luckily only 3 here)
Thanks in advance.


The version of anything would be useful.

FreePBX, Endpoint Manager…

Endpoint Manager version
PBX Firmware:
PBX Service Pack: 1.810.210.57-1
SNOM Firmware version 8.4.35

Let me know if you need anything else.
Thanks for fast response.

Has anyone had a chance to look into this now that i have actually included some useful info ??? (sorry about lack of info in original post)

It’s working fine in my lab. So no. No ideas as to what is going on with you.

i updated asterisk to 1.8.11 and then a couple of days ago i had a go at reprovisioning the phones and it seems to work now…
computers huh ??? got to love them …