Unable to make video calls with Yealink VP59 & T58A with camera phones through FreePBX

Not sure if this is the right place to ask I am unable to make video calls with Yealink VP59 and T58A with camera phones through our FreePBX system which has recently been configured to allow us to use video calls. We have been unable to make video calls with either but the SIP calls are working perfectly.

Our Voip Service Provider (MBIT) checked FreePBX and the codecs and has advised that they should work but identified an issue with the phones themselves, in that they were not responding when they received a request to initiate a video session.

We contacted Yealink for assistance and they have advised that the phones configuration file must contain ‘account.1.video.enable=1’ to allow video calls to operate. They requested that we download the phones configuration files, add ‘account.1.video.enable=1’ and then upload the updated configuration file back into the phone, when we do this the video calls should work.

We have downloaded the VP59 configuration file, added ‘account.1.video.enable=1’ to the file and then saved the file. We then upload the file and confirm (have also tried rebooting the phone). The phone still cannot make or receive video calls, when we then download the updated configuration file from the VP59 phone the added line containing ‘account.1.video.enable=1’ is gone from the configuration file (as though it was never added).

We have the commercial End Point Manager installed, should we be updating settings in the Yealink VP59, should we be adding an entru to the VP59 basefile to pass the required ‘account.1.video.enable=1’ through to the phone automatically, if so how do I enter this?

Has anyone experienced issues like this and solved them? Is there anything in FreePBX that may be contributing to these issues? Any suggestions would be appreciated.

PBX Version:
PBX Distro: 12.7.8-2107-3.sng7
Asterisk Version: 16.16.2

Yes. This is likely the problem. Once the phone reboots, it repulls the config from EPM.

You can fix this in EPM by going to Basefile edit for the template and adding the option if it does not exist.




Scroll ALLLLLLL the way to the bottom to find Add Entry.

Set the parameter to account.1.video.enable and the value to 1
Choose which models to apply to for this template.
Then click change basefile.

Go to your extension list and rebuild/update. See if that helps. It should at least make sure the setting survives reboot.

I do not have any video capable phones on my wall so no way to test anything.

Added to VP59 basefile and this entry shows in red while other entries are green

account.1.video.enable = 1

Rebooted VP59 and setting was not pulled through to phone, updated VP59 config file manually but again was removed from file on upload.

It is supposed to. All changed or new entries show red. Did you rebuild everything properly in EPM? This isn’t something that only works sometimes.

thinking a bit outside the box on this one - many video-capable sip endpoints rely on Symetric RTP / that is they wont send any video until they have received video on that same call.
a problem with your contact header (externip?) or many other things could result in a failure to make video calls.

heck… I had a door phone (keypad and camera. no physical screen) that wouldn’t send video until it received a video stream…

I rebuilt the EPM using the ‘Save, rebuild and Update Phone’ option. then I went to the phone and went to Auto Provision and clicked the ‘Auto Provision Now’ button, I then rebooted the phone for good measure.

I exported the config.file and opened it and the ‘account.1.video.enable=1’ was not in the file. I suspect that the auto provision function is working fine as the OPUS codec which is also not in the basefile disapeared from the VP59 config file (I am able to add and save the opus codec lines provided by Yealink to the VP59 config file).

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.