Unable to locate the FreePBX BMO Class 'Oembranding'

After updating and upgrading my brand new system I’m presented with following error when opening the webui:
Exception (404)

Unable to locate the FreePBX BMO Class 'Oembranding’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install oembranding 2) fwconsole ma enable oembranding

When I try to install the oembranding module I get the following error:
[FATAL] Unable to load oembranding as no license was found for this product.

Possible you lost your deployment id. If you can’t get it registered, open a support ticket.

I doubt it, when I run the update commend from /var/www/html/admin/modules/sysadmin/bin/
I get the following:
[[email protected] bin]# ./update
Updating deployment 729XXXXX…Done!
Licence NOT CHANGED

It’s a new system and I haven’t configured anythig, just ran the update as described on the wiki:

[Upgrade Your PBXact Version SNG7 or newer]

Doens’t seem really fair that I have to pay for support to get my new system to work.

This is a pbxact system, no? If so, free support for bug fixes.

Indeed, but I can’t create a ticket without support credits?

PM sent.

Per your pm request for recovery procedure for UC60:
https://wiki.freepbx.org/display/PPS/PBXact+System+60+and+100+Recovery

If you also need to create install media:
https://wiki.freepbx.org/display/PPS/Converting+the+ISO+file+to+USB+Key

I found out that my system somehow got a different deployment ID.
I received the correct deployment ID from the vendor from which I’ve purchased the system.
However when I Try to link the deployment ID I receive the following error:

[[email protected] bin]# fwconsole sa a XXXX9000
Attempting to activate against deployment ‘XXXX9000’
Running /var/www/html/admin/modules/sysadmin/bin/activate_existing XXXX9000
Asking for deployment XXXX9000…Error!
This deployment is already licensed to a different host. It needs to be unlinked through the portal.

What is the correct procedure here?

Add details to the customer service ticket you already have open.

I’ve added the details in the ticket, could you please assist as this is becoming quite urgent

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.