Unable to leave voicemail > goodbye

Hello all,

Got an odd issue.
It appears that no one can leave voicmails.
I get the following in my logs.
I have checked and made sure the folder exists, and asterisk:asterisk owns it.

2016-12-06 09:58:09] WARNING[28094][C-0000367d]: file.c:1300 ast_writefile: Unable to rewrite /var/spool/asterisk/voicemail/default/3174/tmp/6SWRvm.mp3
– x=0, open writing: /var/spool/asterisk/voicemail/default/3174/tmp/6SWRvm format: mp3, (nil)
[2016-12-06 09:58:09] WARNING[28094][C-0000367d]: app.c:1787 __ast_play_and_record: Error creating writestream ‘/var/spool/asterisk/voicemail/default/3174/tmp/6SWRvm’, format ‘mp3’

Under Settings > Voicemail Admin > Settings > General what is your File Format set to?


FYI, running Asterisk (Ver. 13.12.2)
Incredible PBX 12.0.74

remove mp3 from the options, submit your changes, apply the config, and then test. Only formats available are wav49, gsm, wav, and g723sf as far as i know mp3 has not been added to voicemail but can be used for MOH.

Thank you! That solved that problem, however I now have a different one.
When the attachment is emailed, it will not play on windows or android.
I tried wav and wav49, same thing. :frowning:

is the message just blank or are you getting an error? I know personally we don’t have an issue with that and we have our file format set to wav|gsm on our system.

I get a wav attachment, but it wont play.
If I call Vm, it plays fine.

What I’m asking is by don’t play do you mean:

it’s playing but no audio (can see timer ticking on file but no audio)?
It’s a blank file (0:00 - 0:00)?
Is there an error message saying something is wrong with it?

so, it seems no matter how long a message is left, it still makes a file about 300 bytes.
and when I try to open it with Windows media player, it says “windows media player cannot play the file”.

Is it sending the proper format? What’s the file extension?

good catch.
Mailcmd is /usr/local/sbin/sendmailmp3 which is how it was installed.

If it matters any, I do prefer mp3 because it works better on droid.

you could try the below link:


It has a section for sending voicemail emails as MP3 in it. Could be helpful but requires some work on your end.

Sooo lame!

Seriously though… turned out Lame was not installed.
Installed it and it works perfect now.
Thank you very much for your help.


You’re welcome. Glad everything worked out.