Unable to install FOP2 on Distro 1.817.62

I have just installed the distro version 1.817.62 and when I try to install the fop2 with yum install fop2-fpbx I get this error. Any ideas?

Downloading Packages:
fop2-fpbx-2-2.26.2.i386.rpm | 7.4 MB 00:06
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : fop2-fpbx-2-2.26.2.i386 1/1
grep: /var/www/html/panel/op_server.cfg: No such file or directory
Starting Flash Operator Panel 2: Can’t load ‘/tmp/par-root/cache-4b3df8b00ea32d78fbcfc645d56579285258145c/aaf44dba.so’ for module Filter::Crypto::Decrypt: libcrypto.so.6: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230.
at /usr/lib/perl5/site_perl/5.8.8/PAR/Heavy.pm line 128
BEGIN failed–compilation aborted at /tmp/par-root/cache-4b3df8b00ea32d78fbcfc645d56579285258145c/inc/lib/Filter/Crypto/Decrypt.pm line 37.
Compilation failed in require at script/fop2_server.pl line 1.
BEGIN failed–compilation aborted at script/fop2_server.pl line 1.
Backing up /etc/asterisk/extensions_override_freepbx.conf to /etc/asterisk/extensions_override_freepbx.conf.bak

Cleaning and updating /etc/asterisk/extensions_override_freepbx.conf …

Creating /etc/asterisk/extensions_override_fop2.conf …

Reloading asterisk dialplan…

fop2-fpbx.i386 0:2-2.26.2


I have requested new RPMs for Centos 6 from the FOP2 guys a few times now but still have not received any. Once we get some updated RPMs we will include them in the Distro. Sorry.

I installed Fop2 manually with Fpbx config module manually and the Centos 6.x adjustment and that works fine. Just for info.

Yes, Nicolas at Asternic provides the rpm’s to us. They are usually a bit behind. I find it best to simply install the latest version from fop2.com

We have gotten a new 32bit RPM from Nicolas for FOP2 and put it in the latest yum repos for each track. You should be able to yum install it now. Still waiting on 64bit

Same error here.

service fop2 restart gives:
grep: /var/www/html/panel/op_server.cfg: No such file or directory

There is no panel directory and I cannot find op_server.cfg also.

I know there some troubles with Centos 6.x wich can be fixed:
Currently CentOS 6.x is currently not supported. To make FOP2 work on CentOS 6.x make the following link
ln -s /usr/lib64/libcrypto.so.10 /usr/lib64/libcrypto.so.6

But it does not solve the frep: notice as seen above.
Tried to install new Distro and same thing happens.

I think the script for Freepbx install is broken for new distro’s.

Here is a solution to FOP2 on CentOS 6. I found this in the FAQ section at www.fop2.com.

Is there a FOP2 version for Centos 6?
We are working on a custom binary for Centos 6. In the meantime, you can use the Centos 5 binary, the only thing to do is to create a symlink for libcrypto so it works correctly:

In a 64 bit system the command is:
ln -s /usr/lib64/libcrypto.so.10 /usr/lib64/libcrypto.so.6

In a 32 bit system the command is:
ln -s /usr/lib/libcrypto.so.10 /usr/lib/libcrypto.so.6

I am using 64 bit so my installation procedure was as follows:
ln -s /usr/lib64/libcrypto.so.10 /usr/lib64/libcrypto.so.6
rpm -ivh http://yum.freepbxdistro.org/pbx/1.1010.210.62/x86_64/RPMS/fop2/fop2-fpbx-2-2.26.2.x86_64.rpm

FOP2 seems to be working correctly for me now