Unable to install EndPoint Manager

Just installed the latest version of Freepbx Stable-6.12.65. After the initial setup, I was trying to install the Endpoint Manager Commercial Module from the Module Admin. It shows the module is local available. When I try to install it, the GUI just shows “installed endpoint” message but never finish. when I try to install the module from the command line. I got the following message and it won’t install.

[[email protected] ~]# amportal a ma install endpoint

Fetching FreePBX settings with gen_amp_conf.php…

PHP Fatal error: Call to undefined function endpoint_getglobalsettings() in /var/www/html/admin/modules/endpoint/install/xorcomInstall.php on line 0

Any idea why???

What version of EPM are you trying to install?

It’s version 12.0.0.22. Broken module or bug???

Just tried version 12.0.0.23. Same result.

The following modules are disabled because they need to be upgraded:
endpoint
You should go to the module admin page to fix these.

PHP Fatal error: Call to undefined function endpoint_getglobalsettings() in /var/www/html/admin/modules/endpoint/install/xorcomInstall.php on line 0

FreePBX 12.0.11

Hi,
I am receiving the same error. I have tried to update through the GUI and the command line. I am now unable to upgrade the REST phone application, because of this error.

I am running Endpoint manager v12.0.0.21

Thanks

Michael

Hi,
I am also getting the same error below

PHP Fatal error: Call to undefined function endpoint_getglobalsettings() in /var/www/html/admin/modules/endpoint/install/xorcomInstall.php on line 0

I am getting this trying to upgrade from 12.0.0.22 to 12.0.0.23. I have freepbx version 6.12.65-21. Until this is upgraded I can not upgrade the REST Phone Applications.

Thanks,
Marc

I believe we have found the issue and it will be fixed in version 12.0.0.24. I should have it published shortly.

It still does not work. I am still getting the following.

PHP Fatal error: Call to undefined function endpoint_getglobalsettings() in /var/www/html/admin/modules/endpoint/install/xorcomInstall.php on line 0

Marc

12.0.0.24 has the same problem. Please fix it.

Missed a spot. 12.0.0.25 works and was tested.

Thank you that fixed it.

Marc

Yes, that works now. Great job. Thanks.