Unable to get new features working in 2.9

I upgraded to 2.9 beta, all modules are current as of right now.
I also upgraded Asterisk to 1.8.3.

One of the first new features I am trying to get to work is “auto intercom answer on internal calls”.

I enable x202 for this, but internal calls to 202 still ring like normal. I can make *80202 intercom calls to 202, and that works. It is an Aastra 57i.

Here is a dump of the test call:


ahh, that’s a bug, should be != “”

#4989 fixed, not yet published though.

Thanks, I see which line makes the decision. I don’t immediately see why it is failing. Everything is configured like you said. We use *80 all the time.


This is true, so it doesn’t intercom.
I don’t understand what that field is.

You say:

Isn’t that backwards?

Could you tell me where the decision is made for intercom calling?


I haven’t found it yet…

the syntax error is not related and has already been fixed.

the intercom attempt is part of macro-exten-vm

You also have to make sure that your intercom feature code is enabled (*80 default) which it used to not be enabled at install time though new systems starting 2.9 it is enabled when first installed. (This needs to be enabled or the paging module will not generate the dialplan necessary for it to work, I guess we could detect that and inform of the issue…).

you need to have the paging module installed for it to try it, and of course you need it configured correctly, either forcing every extension or enabling the specific target extension.

The code generated is going to look different depending on various configuration choices but here is an example of what the code looks like where it would be attempting to to the intercom all if appropriate:

exten => s,n,GotoIf($["${AMPUSER}"=""|${LEN(${FROM_DID})}|"${DB(AMPUSER/${EXTTOCALL}/answermode)}"!="intercom"|${LEN(${BLINDTRANSFER})}|"${EXTENSION_STATE(${EXTTOCALL})}"!="NOT_INUSE"|"${CC_RECALL}"=""]?macrodial)
exten => s,n,Set(INTERCOM_RETURN=TRUE)
exten => s,n,Gosub(ext-intercom,*80${EXTTOCALL},1)
exten => s,n,Set(INTERCOM_RETURN=)
exten => s,n,Set(INTERCOM_EXT_DOPTIONS=)
exten => s,n(macrodial),GosubIf($["${INTERCOM_CALL}"="TRUE" & ${LEN(${BLINDTRANSFER})}]?clrheader,1)
exten => s,n,Macro(dial-one,${RT},${DIAL_OPTIONS},${EXTTOCALL})

you are calling a follow-me,

by it’s very nature, a follow-me will never auto-answer as is the case with any ringgroup scenario and also an agent of a queue.

Same result.

Here is a trace: Pastebin

Also, notice the syntax errors at line 27?