Unable to find any soundfiles in asterisk-core-sounds-en-g722-1.5

For some reason, im unable to install/activate module soundlang.

On installation through webgui i get a Whoops.

Doing it from CLI gives:

Not sure where i should start checking… Any suggestions ?


When was this? The evening before last there was a maintenance window for the mirror and yum rpm servers. I just tested and not seeing any issues here, are you still having this problem?

Yes, the problem seems still there, i just tried it again.

Downloading the package seems to work fine. Its the 'installing core-sounds-g722 where it seems to fail.

Maybe this helps, the full exception from GUI;

During sounds install, the tarballs are saved to /var/lib/asterisk/sounds/tmp. There is also a zero byte matching file .asterisk-core-sounds-en-g722-1.5 in /var/lib/asterisk/sounds/. I suspect the g722 tarball is corrupt or perhaps bad permissions. I’m not sure how to force a new download tho. It may be enough to delete (or move to tmp) one or both of those files and attempt a module re-install.

That was a good hint.

I moved the mentioned files to a temp location, and also moved the zerobyte matching files.

then ran fwconsole ma remove soundlang and fwconsole ma downloadinstall soundlang and voila, problem solved.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.