Unable to dial out internationally


#161

Yes, look at line 11:
Contact: <sip:3178@24.103.126.86:5060>
Asterisk is supplying a public IP address, because it does not recognize that 10.10.10.97 is local, even though you presumably updated that setting and restarted Asterisk.

In the file /etc/asterisk/sip_general_additional.conf please post the value of any lines beginning with localnet

Also, in the Elastix GUI, post a screenshot of Settings -> Advanced SIP Settings -> NAT.


(Honor's Haven It) #162

The Etc/asterisk/sip_general_additional.conf has no such setting.

image

Here’s a screenshot of the settings for the softphone’s extension.


#163

I need a screenshot of the NAT settings for the PBX (not settings specific to an extension or trunk).
Possibly, your version is different, but it is probably under Settings in the GUI.

Also, if the file /etc/asterisk/sip_general_additional exists on your system, post the entire contents. If not, post a directory listing of /etc/asterisk.


#164

Again

Etc/asterisk/sip_general_additional.conf

doesn’t exist but

/etc/asterisk/sip_general_additional.conf

does, linux is both case sensitive and very aware of where your ‘root’ is when you issue commands,.

(having cleaned up your duplicate logs you need to reload logger from the asterisk cli)


(Honor's Haven It) #165

Sorry, my mistake, I’m looking for the SIP settings now…


(Honor's Haven It) #166

image

These are the only settings I can find, Maybe enabling Anonymous sip calls could help?


#167

You will need Elastix Support here, unfortunately it doesn’t exist any more.

Allowing anonymous calls on an Elastix system is inviting all sorts of fraudulent calls within a short period of time. Well actually a dumb idea on ANY PBX using VOIP


(Honor's Haven It) #168

So the soft phone option isn’t going to work here. I hope that the numbers we try and call out to will work on the hand sets at this point. I’ll close the thread once the sales team confirms they can dial out. I’ll report back here once they try and call out.


#169

Good Luck, it was a long journey for all :wink:

(You really need a consultant that better understands ‘stuff’ to fix things ‘properly’ though)


#170

I think this may apply to your system:

If you have /etc/asterisk/sip_general_custom.conf and it contains localnet parameter(s), remove those (save a copy first, in case you mess up).
Then, edit Local Networks on this screen to be
10.0.0.0 / 255.0.0.0
Submit, Apply Configuration Changes, restart Asterisk, test softphone outgoing.


(Honor's Haven It) #171

Well holy crap, I was able to actually find these settings, I’m attempting this now, I’ll respond once I have everything squared away


(Honor's Haven It) #172

it’s asking for an External IP as the field was blank. What should I add? just add what I use to log into it normally or?


#173

Very strange, because your previous paste showed the system as substituting 24.103.126.86, assigned by Charter (Spectrum) to THOR - 560 WEST 126TH ST LLC. Is that you guys? Asterisk must have gotten that address from somewhere, possibly a customized file.

What does
grep 24.103.126.86 /etc/asterisk/*conf
show?


(Honor's Haven It) #174

/etc/asterisk/sip_nat.conf:externip=24.103.126.86

If anything, putting in the local IP in that field managed to get the softphone to dial out without much issue actually. As far as I can tell, the softphone has no more issues with any form of dialing out. Still, Dialing out on the desk phones for Dubai cuts out at the 01197 part, but the soft phone has no such issue. The sales department aren’t a fan of having their PCs dial out for them though. So the system itself isn’t stopping international calls, but it appears to be the phones themselves not properly allowing it.


(Honor's Haven It) #175

At this point, I’m not sure what else we can try to do to get the desk phones to dial out that specific number. If anyone has any sugguestions, I’m all ears. Otherwise, I’ll close the thread on Friday this week (22nd).

I again, thank everyone here who posted here with ideas and methods to test and get the calls to finally dial out!


#176

Some possible approaches:

  1. Find out why the phones are pulling the wrong config file (or none at all).

  2. Set up an Outbound Route so (for example) the user dials 81 29X XXX XXXX and 011 971 5X XXX XXXX gets sent to the trunk.

  3. Sign up for (example) Localphone.com Once set up, the user dials a local number and it rings his contact overseas. $0.159/min. to UAE. 5-minute free trial.