Unable to connect to provider

good day i have something annoying i am trying to connect via the sip truck to call2teams on my freepbx on premise server but it doesn’t work when i look at the logs i get this error every time [2023-07-20 05:00:08] WARNING [13745] res_pjsip_outbound_registration.c: no response received from 'sip:aeuwa10.call2teams.com:5061 ’ on registration attempt to ‘sip:[email protected]:5061’, try again in ‘60’ and when I go to asterisk information it says refused and when I look at their portal it says refused how can I solve this I really have tried everything but I can’t get it working I would like to hear from you thanks in advance with kind regards Tobias

1 Like

Did you try calling your provider’s support team?

Seems like you are trying to register on port 5061. That might be correct but it’s more typical that a SIP trunk provider is listening on port 5060. Make sure you have those settings correct.

Note that 5061 is the ‘standard’ port for SIP over TLS. If your provider documentation specifies TLS, on the PJSIP Settings → General tab for your trunk, set the Transport to . You may need to set up or configure a certificate before the trunk will actually work, but you should at least see a more informative error message.

1 Like

good day i tried to call my provider but they redirect me to this community so that’s why my question on this community

good day i have tried on many ports but my provider blocks port 5060 in and out so and i did try to connect on 6001 which supports tcp but i also get the following error no response from provider

Expand on who your ‘provider’ is and what you are expecting them to provide, also tell us what they do provide amd what they deny.

AFAIK, no spoken or written error message in FreePBX contains the word ‘provider’. What device played or displayed this message? Does the PBX otherwise work properly (calls between extensions are ok, incoming and outgoing calls from/to the PSTN are ok)?

The only detailed documentation I could find for call2teams was

In this setup, call2teams is set up as an extension on the PBX (not a trunk) and registration is from c2t to the PBX. Possibly, that configuration will give you the functionality you need. If not (a trunk is required), just guessing here, the trunk (at the PBX end) may need to receive rather than send registration. What documentation did they send you?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.