Unable to connect to Asterisk Manager

On a brand new installation of ubuntu 14.04.4 LTS, with Asterisk 13.7.2, and FreePBX 13.0.98 I get the red indication on top “Can not connect to Asterisk”.

When I issue (as root and as user asterisk) the command : /var/lib/asterisk/bin/retrieve_conf
I get
Exception: Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting in file /var/lib/asterisk/bin/retrieve_conf on line 13

Please help
I tried reinstalling again with the same result.
What am I missing?

I saw a similar problem. Try running “fwconsole restart” from the root console. That should restart asterisk which seemed to be a problem after reboots.

I have tried that with no success. What am I missing here? after a fresh install it is very weird

I was having a problem setting up FreePBX on an old PIAF system using the “Upgrader”. Problems with userman, the database, etc. I finally got all of those resolved by getting everything in “Module Admin” installed and up to date.

The sequence went something like this:

  • Upgraded FreePBX with Asterisk running. Could not reload because of a database error.
  • Changed the permissions on fwconsole so that it was executable again. Got fwconsole working.
  • Finished upgrade using “Module Admin” interface from FreePBX. Worked.
  • Tried running fwconsole again to restart Asterisk. System couldn’t find fwconsole.
  • Used “find / -name fwconsole” and tried to run that. There were two - one was a bad symlink - the other wasn’t executable again.
  • Changed mode using “chmod +x fwconsole” and got it running again.
  • Ran fwconsole to change permissions. Got a complaint about language sound files.
  • Forced install of lang pack. Problem solved.
  • Hit “Reload” in FreePBX. Everything worked fine.
  • Ran “Module Admin” Monday night.
  • Everything completed and instead of “Reload Config” it says “cannot communicate with Asterisk”.
  • Used ‘fwconsole’ to start Asterisk. Up and running.
  • Still can’t connect with running Asterisk.

Note that Asterisk is running, and all of the modules are working. All of my extensions work, all the inbounds are working. FreePBX seems to be working fine, except that it has no connection to Asterisk, and Asterisk is running just fine, only without communicating with FreePBX. Just f-ing odd.

It’s been a circuitous trip, but I seem to be stuck at the same place as you, only I didn’t get here from a fresh install.

As always, if just the two of us are seeing this, it’s probably something we did, but I thought you’d like to know that you aren’t alone here.

@lhalepH @cynjut @rdesilva

FreePBX TAKES over the machine. Asterisk and Apache need to run as the user/group asterisk.asterisk. If Asterisk is not running as the user “asterisk” FreePBX isn’t going to be able to connect to it and you’re going to see that error.

You can do fwconsole chown to fix persmissions issues. If Asterisk is already running as anything but asterisk do: asterisk -rx “core stop now” Once it’s stopped, do fwconsole start

You should also look at:

Make sure your setup follows the proper instructions for the OS you are using.

I have followed the guide:

step by step,
with no luck

I have also install on a VM in order to experiment on resolving the issues
no luck as well

I also found the following issues and resolved them on my own
(weird on a brand new installation following a tested guide)

/etc/asterisk/asterisk.conf —> removed the (!)
touch /etc/asterisk/manager_custom.conf -->never created
touch /etc/asterisk/manager_additional.conf -->never created

enabled =yes -->(was no)
permit= -->(was commented)
secret = amp111 -->(was commented)

still on fwconsole reload -->> unable to connect

After feeling desperate, I tried on a new installation again the following guide


which failed on the section:


Checking for PEAR DB…FAILED
[FATAL] PEAR must be installed (requires DB.php). Include path:

Am I the only one trying to follow step by step the guides and failing?

If you are setting up the manager config manually, note that the secret is probably not “amp111.” You will find the manager secret that FreePBX wants to use in /etc/amportal.conf around line 96, variable AMPMGRPASS.

After following on two different machines default installations of Ubuntu 14.04.4 LTS and the guides from

both fail

then I start experimenting trying to figure out the problems.
I do not consider myself a newbie, (not after 18 years experience) but something is serious wrong here!!
and someone should point it out!!!

here is what I have tried:

attempt 1 on physical machines and VMs
follow guide carefully : http://wiki.freepbx.org/display/FOP/Version+13.0+Installation

always fails on Exception: Unable to connect to Asterisk Manager from
/var/lib/asterisk/bin/retrieve_conf, aborting in file
/var/lib/asterisk/bin/retrieve_conf on line 13

attempt 2 on physical machines and VMs

follow guide carefully : http://wiki.freepbx.org/display/FOP/Version+12.0+Installation
fails on ./install_amp step (unable to complete guide)

now attempting 3 on VM with debian 8
I will let you know

Using the distro will save you a bunch of time. Why not try it?

which one do you suggest?

Why don’t you solve one error at a time, and then if there are omissions in the guide, all benefit from the corrections?

If there is a problem with the manager.conf that is generated, please look at my previous suggestion and fix it and file a bug about the installer.

If the installer requires PEAR and your system doesn’t have it (as the message indicates), then install PEAR and proceed.

I was attempting to solve one problem at a time, mainly on attempt 1 where it seemed that was only one problem, but was stuck for so many days with no luck.

There are big differences between FreePBX 12 and 13 including in the installer and command line tools so I would suggest just sticking to one version and working through it. I run FreePBX 13 on Debian 8 and have also installed it on Ubuntu 14. I don’t remember any big problems but I probably worked through small errors like these as I went. Please try the 13 install and fixing the manager config as you had been doing.

The distro also runs the installer from 13. I will check later today doing this manually but if there were issues with the installer the distro would have issues as well.

I will give it a go on the freepbx distro, I don’t seem to find the problem on the Exception: Unable to connect to Asterisk Manager problem.

the asterisk is working,
the freepbx gui is working (besides the red indication)
I have chown and chmod everything I could found related
I have no iptables running, services are running as they should
tried various fwconsole commands

still no luck

20min left on downloading the distro and give it a go on my physical machine

with freepbx distro I am up and running in 1 hour, amazing

My problem was that the ACL for the server didn’t allow the manager users to connect from The local network was OK, just not localhost.

Looked at /var/log/asterisk/full and it told me exactly where the problem was. Took about 30 seconds and a quick reload to fix it.