Unable to connect softphone to FreePBX


(Improv Clint) #1

I have FreePBX running on aws. Unfortunately, I can’t get any softphones to connect to it. I’m not sure if it is a configuration problem on FreePBX or if it is a hardware issue on possibly my router. I am very new to FreePBX. I used Youtube tutorials to set it up and it appears to be up and running correctly. I followed the tutorials on creating extensions and connecting a softphone but none of the softphones will connect. I’ve tried the 3CX and microsip. Any help would be very appreciated. Thanks.


(Sergio Lobera) #2

Hi, did you take a look at your firewall ? Go to Connectivity > Firewall > Networks > Add your public ip (from where you are trying to register) as “trusted”, then try again.


(Improv Clint) #3

Thanks for the reply. I don’t have the firewall module enabled. Also, I wasn’t sure which ip is my public ip. I notice several different ip’s within FreePBX. For instance, under Settings > Asterisk SIP Settings, it shows External address and Local networks. Then under Admin > System Admin > Network Settings there’s a Static IP and Gateway. I’m generally confused.


(Improv Clint) #4

I set up the firewall. I have my public ip on there. I was able to get two softphones to call each other but not out. The mic and/or speakers are not working when I do though. Also, I am unable to register my DID numbers using sip. Pjsip seems to work but not sip. Attached is I get when I try to register sip.

Thanks.


(Dave Burgess) #5

PJ-SIP is SIP, just a different channel driver. Normally, PJ-SIP is assigned to port 5060 and Chan-SIP (deprecated and no longer maintained) is on port 5160.

There are a lot of things in this thread that confused me, so I’m going to make some suggestions that may or may not help you.

  1. The port you access the phone system with (5060 or 5160) determines which channel driver you are using.
  2. SIP phones can connect to either, but they must be set up in the channel driver as Chan-SIP extensions or PJ-SIP extensions.
  3. You do not need a trunk to connect extensions, but you do need a clear network IP path to get from the phone to the server and back again. This may require firewall settings, NAT configuration, router changes for default address passing, and possibly a VPN to make the extensions “local” to your PBX. Note that setting up an instance on someone else’s Linux Server (e.g., “The Cloud”) increases the complexity of your setup and may or may not decrease your ability to manage the connection.

(Improv Clint) #6

Thanks so much for your reply. I’ve learned so much going through this process. Right now, I’ve been able to get a trunk registered with my provider along with connecting microsip softphone to my FreePBX. The issue I’m now having is ghost/phantom calls coming in. After some research, I found out that they are ip sniffers looking for vulnerabilities. I believe I can stop them through my router. I’m looking at the firewall settings on my router and I think I need to whitelist the ip for my FreePBX. Another issue now is that I’m not able to receive incoming calls. Not sure what I’m doing wrong with that. Anyway, I’m attaching a screen shot of my router setting screen. Please let me know what I need to configure so I no longer get these ghost calls from ip sniffers. Thanks.


(Jared Busch) #7

Just use a PJSIP trunk with VoIP.ms it works fine. The only thing you need to do is lower the default expiration from 3600 to 120


(Dave Burgess) #8

You can also turn on the Integrated Firewall and block anyone that isn’t in your “white list” of addresses that want to connect to the server.

To be clear, this list is your ITSP IP addresses and anyone that needs to connect to your PBX as an extension. Lock everybody else’s IP address out from 5060.


(Improv Clint) #9

I believe I have solved all the issues I was having. I’m able to make calls and receive calls on both my phone numbers with my softphone. I setup port forwarding on my router to no more ghost calls are coming in. I want to thank everyone for their help. I’ll make sure to post here if I have questions once again. Thanks again.