Unable to connect my grandstream phone via TLS

Hello everyone, I hope you’re doing well.
I’ve been trying to solve a requirement for several days now, but I can’t figure it out.
I’m trying to connect a Grandstream 1628 phone with firmware version to my FreePBX system via TLS. I have no issues with UDP at all, but when I try to connect via TLS, it can’t even log in. I don’t quite understand what the problem is because I’ve tried everything. I created a certificate and uploaded it to my phone in .pem format. I followed all the instructions on this page TLS and SRTP - Phones - Documentation to the letter, but nothing works. We were only able to make it work with some softphones (not all of them).
In my router, I can see that the phones are reaching the port 5061 properly, but still no luck. There isn’t much information in the logs either. If someone has experienced this problem before and could lend me a hand, I would be extremely grateful. I’ve been at it for several days, and it’s driving me crazy.
I apologize for my English; it was translated using ChatGPT. I hope it is understandable.
Best regards, thepexz

Have you restarted Asterisk after following the documentation?

I restarted it, but still nothing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.