Unable to change network settings

Hello Everyone,

Im having trouble making changes to my network settings under system admin. When i click on network settings everything is grayed out and the network interface box just spins. Related topic I cant get my sip station trunk to register. I can ping the trunk from the CLI but the sip module shows it wont register. see pics

You should assign a static ip to your pbx, or set a static ip in your router for your pbx,

Then you should be able to do what you want to do

Using dhcp is not recommended,

I agree DHCP is not a good idea however something is just not right with my system. I am unable to adjust my network settings via the GUI and im not sure how to do this from the CLI. This started after updating to freePBX 13.

Are you completely sure that the interface shows up in your FreePBX implementation. Many older (and a couple of new) interfaces do not have drivers.

Log into the console as “root” and use the ‘dmesg | more’ command to make absolutely certain FreePBX and the attendant operating system code recognize your eth0 port as an eth0 port.

Im not sure what i am looking for with the dmesg command. See Below

ip_tables: © 2000-2006 Netfilter Core Team
r8169 0000:01:00.0: eth0: link down
r8169 0000:01:00.0: eth0: link down
ADDRCONF(NETDEV_UP): eth0: link is not ready
r8169 0000:01:00.0: eth0: link up
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
r8169 0000:01:00.0: eth0: link down
r8169 0000:01:00.0: eth0: link up

OK - the OS knows your Ethernet port it there.

It the console again, type “ifconfig -a”. This will give you a list of all of the settings for all of the network interfaces. Make sure eth0 is listed there too. If it is, paste the settings into your answer.

[[email protected] ~]# ifconfig -a
eth0 Link encap:Ethernet HWaddr B8:AE:ED:35:97:B8
inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: 2601:244:c100:2010:baae:edff:fe35:97b8/64 Scope:Global
inet6 addr: fe80::baae:edff:fe35:97b8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:335827 errors:0 dropped:0 overruns:0 frame:0
TX packets:238621 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:161782039 (154.2 MiB) TX bytes:149443213 (142.5 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:446082 errors:0 dropped:0 overruns:0 frame:0
TX packets:446082 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:41455936 (39.5 MiB) TX bytes:41455936 (39.5 MiB)
also ran
ifconfig etoh0

[[email protected] ~]# ifconfig etho0
etho0: error fetching interface information: Device not found
[[email protected] ~]#

OK - so the interface is getting set (it’s 192.168.0.100). Are you trying to set it to something else or are you trying to set Asterisk to use it?

If you want to change the address, you can do that in the /etc/sysconfig/network-scripts/ifup-eth0 file on your server.

Dave, I really appreciate your help… Im not sure what i am trying to do LOL I was trying to figure out why my machine would not talk to sipstation. When i went to the network settings in freepbx GUI everything was grayed out and i could not make any changes that has then led me to this point.

I tried the /etc/sysconfig/network-scripts/ifup-eth0

[[email protected] ~]# /etc/sysconfig/network-scripts/ifup-eth0
-bash: /etc/sysconfig/network-scripts/ifup-eth0: No such file or directory
[[email protected] ~]#

[[email protected] ~]# amportal restart

Please wait…

/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_dahdiconfig: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_endpoint: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_pagingpro: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_restapps: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_ucp: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_ucpnode: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_vqplus: No such file or directory
/var/lib/asterisk/bin/freepbx_engine: line 222: /var/lib/asterisk/bin/freepbx_engine_hook_xmpp: No such file or directory

Look around in the /etc/sysconfig/network-scripts directory and find the right filename - the one I used is obviously incorrect.

So, the problem you are actually having is that SipStation can’t talk to your server. You don’t need to change anything in your network configuration. Since you have a NAT address of 192.168.0.100, you need to configure your firewall to pass the incoming traffic from SipStation to your PBX.

There are many tutorials on the Internet about connecting Asterisk to a SIP Provider through a firewall. You probably need to start there.