Unable to boot UC40


(Todd Schacherl) #1

I have a UC 40 that we recently decommissioned from a store we recently closed. I wanted to reuse it for another one of our businesses but when I tried to boot it up it comes up and indicates a problem with the file system. It indicates “/dev/sda2: UNEXPECTED INCONSISTENCY: RUN fsck MANUALLY”

I really don’t care about the install that’s on it so I installed the USB drive I received with the system and booted off of that. I select the full install and then it shows:

Loading vmlinuz…
Loading initrd.img…ready.
Probing EDD (edd-off to disable)… ok

and then the screen blanks and that’s all it ever does.

Any suggestions?


#2

Maybe it is trying to read from the internal HDD. Have you tried fsck’ing the FS?


(Todd Schacherl) #3

I can’t ever get to a system prompt to do anything. Is there another way to run fsck?


#4

You can try booting the UC40 with a gparted live USB stick and run fsck on the disk.


(Eko VoIP) #5

I am having the same issue with a new PBXact 100 - not booting – /dev/sda2: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. (i.e. , without -a or -p options) , trying commands like fsck /dev/sda2 while it requires but no result just hangs on nothing happens, even if you try restarting many times same result, does anybody manged to solve this issue ?


(Dave Burgess) #6

The fsck can take quite a while, so are you sure it’s hanging, or is it just taking a long time?


(Eko VoIP) #7

It looks to me it’s hanging because i waited for it long time 30-40 minutes, and when I run the command on CLI nothing appears below it - like no command taken from the server - weird situation really.


(Todd Schacherl) #8

I was able to get it to run. I had to create a USB stick with a CENTOS iso burned to it. After booting that I was able to select the option to repair a Linux system. I eventually got to a prompt where my drive was mounted at /mnt/sysimage.
I was unable to run fsck initially until I forcefully unmounted that drive. I ran fsck and it only took a minute or two. Rebooted and it came up fine.


#9

Its best to use a filesystem specific version of fsck verbosely

fsck.ext4 -y -v /dev/sda2

-y to answer yes to everything, -v so you can see whats up

But you can’t run that on a mounted filesystem so do that from your “favorite recovery iso”


(Eko VoIP) #10

so after inserting the USB bootable disk I see the options Install CentOSa and troubleshoot, what we should do after this any suggestion - step by step maybe


(Eko VoIP) #11

Hello @rnrstar @dicko @cynjut , I just wanted to inform you that I managed to solve the issue, by creating the USB bootable disk (CentOS7 minimal iso) and booted from usb then
choose Troubleshooting - Rescue Linux, then choose Option 1 - so rescue environment mounted on /mnt/sysimage and then wrote commands:
#fsck.ext4 -y -v /dev/sda2 – result : /dev/sda2 is in use, Cannot continue, aborting
or was telling other time
#fsck.ext4 -y -v /dev/sda2 – result: /dev/sda2 is mounted
then I run this command: # umount -l /dev/sda2 and # fuser -k /dev/sda2
and again
#fsck.ext4 -y -v /dev/sda2 which resulted with success showing some messages like : /dev/sda2: XY files, 4226/4333 clusters … and OK — system booted without problems.
Now when checking with fdisk -l and vim /etc/fstab it’s showing normal situation and values.

Thank you for the help guys.


(system) closed #12

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.