Unable to apply config - retrieve_conf shows Bus error (core dumped)

I’m running Asterisk 11.5 on Ubuntu 12.04.2 LTS

Other than google voice: [i}Google Voice/Chan Motif 2.11.12[/i] I have the standard modules installed.
I installed on Ubuntu with these instructions about 6 months ago and it’s been running great:
http://wiki.freepbx.org/pages/viewpage.action?pageId=1409028

I should have probably left everything alone, but yesterday I checked all modules (except for commercial) and did an “Upgrade All”:
framework 2.11.0.0rc1.8 went to (2.11.0.11)
fw_ari 2.10.0.5 went to (2.11.0.0)
and 26 more modules…

After the upgrade I added a trunk and incoming route and tried to “Apply Config”, I get this error in the GUI:

Reload failed because retrieve_conf encountered an error: 135 exit: 135 Bus error (core dumped)

In /var/log/asterisk/freepbx.log these entries show up every time I attempt to apply the config:

[2013-Oct-07 08:39:10] [NOTICE] (bin/retrieve_conf:329) - [NOTIFICATION]-[core]-[MEMLIMIT] - Memory Limit Changed[/b]
[b][2013-Oct-07 08:39:15] [CRITICAL] (admin/functions.inc.php:384) - [NOTIFICATION]-[freepbx]-[RCONFFAIL] - retrieve_conf failed, config not applied

When running ./retrieve_conf --debug in /var/lib/asterisk/bin as the asterisk user I get this:

[email protected]:/var/lib/asterisk/bin$ ./retrieve_conf --debug Checking for PEAR Console::Getopt..OK Bus error (core dumped)

Otherwise, Asterisk runs just fine.

What I’ve tried to do:

  1. I’ve recompiled asterisk.
  2. I’ve tried to select the “FreePBX Framework” and “FreePBX ARI Framework” and do a Force Download and Install to the latest version again.

Any ideas?

Looks like I resolved the issue, however I don’t understand why.

I re-installed freepbx with:

./install_amp --webroot /var/www/freepbx
amportal a ma installall
amportal a reload

Everything works fine now. Since I didn’t first delete any of the new freepbx modules, it also looks like I’m completely up to date.

When I first tried this, I pulled down the latest freepbx version

svn co http://www.freepbx.org/v2/svn/freepbx/branches/2.11 freepbx

however that failed with

PHP Fatal error: Class ‘notifications’ not found in /usr/src/freepbx/amp_conf/htdocs/admin/libraries/utility.functions.php on line 1360

So I just used the source that I pulled down back on May 14. It’s the same directory so I’ll try and compare the two, but sometimes obviously not identical.

However, that means that the ubuntu manual install instructions:
http://wiki.freepbx.org/pages/viewpage.action?pageId=1409028
may not work very well.

I guess the moral of the story is, don’t use an unsupported OS!

I was able to get it working on Debian 7 by adding:

include ‘notifications.class.php’;

to: /usr/src/freepbx/amp_conf/htdocs/admin/libraries/utility.functions.php

I have the same problem, but I do not understand exactly how you did it - added include ‘notifications.class.php’; ???

I found this file but which line i need to add that “include ‘notifications.class.php’;”?

Hello everyone,
I also had this problem when I wanted to do an update.
After debugged scripts PHP, I resolved this error by adding before class “notifications” :
Open :
/usr/src/freepbx/libfreepbx.install.php
Search :
include($amp_conf[“AMPWEBROOT”].’/admin/libraries/cronmanager.class.php’);
Add before :
include($amp_conf[“AMPWEBROOT”].’/admin/libraries/notifications.class.php’);

Then restart the update :
./install_amp --webroot /var/www