Unable to access old CDR reports and call recordings after upgrade from 15 to 16

Over the weekend I upgrade my freePBX from 15 to 16 via the GUI upgrade module. It seemed to go OK - but today I have found that I can no longer access the older call recordings pre-upgrade. Calls have recorded OK since the upgrade and I can access these.

I can still see the list of the older call recordings, but when I try to access them I get the following error -

Trying to access array offset on value of type bool file:/var/www/http/admin/modules/cdr/cdr.class.php:414

any help or pointers will be very gratefully received.

That error does not match the current release version of that file. Make sure your cdr module is up to date and is a version of 16.x.x

Thank you for your reply.

I have checked the cdr reports module and it is version

Anything else I should be checking?

Many thanks

It appears someone broke mirroring to github so It doesn’t have the most recent code. A bit annoying but what is one to do…
Any way they changed the SQL

The query should work but for whatever reason it isn’t. I would look at old calls in the database and ensure the uniqueid field is populated

Thanks James,

I will delve into the above.

I did notice that the dashboard was saying that the api module 15 was not installed - when I looked at the module admin all the api modules were installed. I did however run fwconsole ma installall - I do have a hot spare installation still running on 15 - I wondering if I should switch back to that until I can get this resolved

After having a fresh look at it - I am still able to download the calls - I just can’t play them directly from the server through the browswer.


I have the same problem here; however, I have only updated all modules on the v15 server. The error I’m getting is: Ajax request broken or aborted for an unexpected reason. Please check console logs for more details.

Developer console shows the following:

The full URL from the error is:

CDR module version:

Update: The same issue is happening on module update of v16, CDR module version:

Update 2: Downgraded the cdr module to version - issue still there.
Downgraded to 15.0.24 - playback works again.

Update 3: v16: Downgraded the cdr module to version - issue still there.
Downgraded to 16.0.46 - playback works again.

Use the following commands to resolve:
fwconsole ma downloadinstall cdr --tag=16.0.46
fwconsole reload

Thanks Kamilk!!! That’s worked for me. :slight_smile:

1 Like

Glad to hear it works for you now.
I have reported this issue: [FREEPBX-24413] CDR Reports - no longer able to play recordings - Sangoma Issue Tracker

Did you know the issue was closed with the reason “Not an issue”.

I am running CDR and also can no longer listen to call recording in the CDR report. This was working perfectly fine before.

@lgaetz was the issue report closed in error? Seems to be the same issue across different systems.

Well, after I downgraded from to 15.0.24, and then upgraded to, I was able to listen to the recordings again - same goes for version 16. Have you tried downgrading and then upgrading?

I’ve just tried this.

I downgrade from to 15.0.24. Whilst on 15.0.24 I can play the call recordings directly from the CDR report. Works fine.

I then upgrade to and it stop working.

I then downgrade again to 15.0.24 and it works fine.

Something must be wrong with

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.