UID was not numeric error

I had uninstalled the REST API module after upgrading to FreePBX 13 to troubleshoot something. Now as I try to download an install it again I receive an error “UID was not numeric”

How can I fix this and get this installed?

You need to upgrade your modules. This was fixed a long time ago.

All my modules are upgraded. The REST API module is the only one I’m having trouble with. Is there a specific module that I need to check the version number on that may be causing this?

Rest API has the fix. I can tell you don’t have this version because the error is coming from line 210 of Restapi.class.php but all that has now is a “}”

You are correct. I don’t have REST API installed at all. I am trying to install it (re-install it, actually), I receive the error when trying to install. It is attempting to install version

Please download so we can get the correct line number

My only option in the module admin is to install version Is there a way to manually install Attempting to install version is what gives me the error.

fwconsole ma upgrade restapi --edge

Do you even require RestAPI? There’s no need for it. You’d proabbly be better off just disabling it and moving on.

Thank you! That fixed it.

I thought the REST API had something to do with the phone apps for Sangoma phones. Maybe I’m wrong about that.

It was used for Phone Apps but we removed the need for it. At some point we will open source Rest API

1 Like

WOOT! Thanks to the powers that be.