UCP Whoops Error

I am getting a “Maximum execution time of 30 seconds exceeded” on “/var/ww/html/admin/modules/ucp/htdocs/vendor/tedivm/jshrink/src/JShrink/Minifier.php:540” when loading the UCP login page. Unfortunately, the Username/password and cloud/spinning gear icon are modal on top of the whoops page!


On latest edge versions:

On distro 12.7.5-1807-1.sng7

Trying to paste screenshot here:

Your system is really slow. Thats what the error means

1 Like

Hmmm, UCP worked fine up until 2 weeks ago or so (not sure which exact update caused it to throw this whoops error).

Thanks for the info, I will try to obtain exact system specs …

  • m


It is an Intel Atom D525 dual core 1.8Ghz CPU with 4GB of RAM. Plenty of free HD space.

We have a small setup - about 15 extensions, rarely more than two lines active at a time.

Is this now considered not enough computing power for freepbx?

The function that is running out of time is only minifying javascript. Raspis don’t have any problem running this.

The way I read Andrew’s response wasn’t “your machine isn’t big enough” it’s “your machine is doing something that is consuming the resources you have.” Minifying JavaScript is trivial, but if your machine is running out of time trying to do it, you might need to look a little deeper.

I’ve had a system react like this once before, and it was because I had a “correctable” error on the hard drive. Every time the machine hit that spot, it would take a few seconds to recover. Note that this is merely an anecdote - a suggestion that you might want to expand your search grid a little bit and make sure something somewhere else isn’t effecting (perhaps catastrophically in the future) the resource allocation on your machine.

Thanks for the advice!

I just did a hd scan with the badblocks command - no bad blocks.

This is a normal distro install, with nothing else installed, so there shouldn’t be anything unintended sucking up resources …

Any other ideas? Thx in advance for anything!

  • m

Still trying to troubleshoot this … I tried restarting the machine, got some interesting errors on the console on startup - see attached.

Any ideas?

Now you have missing files (technically mysql corruption). Missing files and slow drives usually means drive failure.

Thank you for the reply.

Curious - badblocks and smartctl show no issues - and it is 2 Intel SSD drives config’d as a RAID 1 mirror array …

What is your recommendation - backup, reinstall the freepbx distro, and restore?

  • m

PS - for what it’s worth, the rest of the system (calls/vm/cdr/etc are all working fine …)

I solved this:

Increased my php max_execution_time from 30 to 120.

The next time I logged in to UCP, it took awhile (presumably “minifying”) - but subsequent UCP logins are fast, and the system is working fine now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.