UCP playback of recordings not working

Hi there

Using Asterisk 11 with freepbx 12. I cannot play back the recordings of conversations through the User Control Panel, nor can I download them. They appear fine, and I can play them back normally through the CDR report function.

Javaconsole throws out this which is obviously the problem, just don’t know what the fix is :slight_smile:

jsphpg_fe91989dfa3251cc02e379e1aefaaa08.js:88 GET net::ERR_CONNECTION_REFUSED
jsphpg_fe91989dfa3251cc02e379e1aefaaa08.js:88 GET net::ERR_CONNECTION_REFUSED

What browser and version are you using?

Hi Tony

I have tested:

Chrome 64bit 39.02171.71

Firefox 33.1

IE 9 (not sure of subversion). None of them work…

Firefox seems to give a bit more info re java console:

HTTP “Content-Type” of “text/html” is not supported. Load of media resource failed. ucp
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at This can be fixed by moving the resource to the same domain or enabling CORS.

Anything with the words “socket.io” in them are completely unrelated.

Have you tried loading manually?


I hadn’t but did now - that just gives a blank page…

in Firefox I get this:


sorry firefox also gives a blank page, I just wasn’t logged in when I received the forbidden thing

If you are getting a blank page then the file could not be found.

You can run: amportal a dbug

But I doubt you’ll find much more. it’s really a 404. File not found error. (as in ucp can not find the recording)

This might also be a permissions issue. Anyhow I am hoping to put some debug into it and then you could run that and give me the dbug back.

I am also having this issue. From the UCP I can play recordings/voicemail over/through the actual phone, but not through the web interface. I’ve tried also with Firefox 33, Chrome 39 and IE 11. It seems like the playback bar is “frozen” - that is, nothing happens when you click on it.

The download link and playback are the same links. So let’s move past the playback and ignore it

If you can’t download then let me know here.


I reckon I know what the issue is. The calls come in and are sent to a ring group - 999990. One of the extensions has answered, so that call is shown in the ucp interface of extension 400. But because it’s linked to the ring group it cannot be played?

If that were the case you wouldn’t see the play or download link.