UCP phone partially silent

FreePBX 16.0.21.8, Asterisk 19.5
NOTE: I have a working FreePBX 15, Asterisk 16 version to compare against
The problem: If I make and outgoing call with my UCP phone it works fine except for incoming audio. If I call my UCP phone I can see that I have an incoming call but there is no ring tone. I can answer the call and once again there is no incoming video. The fact that the UCP silently rings make me think it’s a different problem than the usual audio problems. I believe if I solve the problem of silently ringing it will also solve the incoming audio problem. I haven’t noticed anything conspicuous when logging.

Any ideas?

I would make sure it’s not an issue with the webrtc client running on your browser/computer. Would you check from the same extension on a different machine?
You could also open the dev tools/console on the browser when receiving a call. Check if there is any errors there.

Many thanks for your input! I have a working implementation which is setup the same way (I think), but it’s just an older version (RPI3/Debian10, FreePBX15, Asterisk16). I just adjust my firewall settings and use this old setup and it works fine. Change the firewall settings to the new setup (RPI3/Debian11, FreePBX16, Asterisk19) and I have the problem described. Looking at the browser dev. tools console is a good idea. I’m going to concentrate my efforts on getting ringing tone on incoming calls, as I think if that works then it will be problem solved.
I have also tried on another laptop with the same results, and SIP/IAX clients work fine.

…also everything looks OK to me when using the dev. tools console.

Further info. It doesn’t matter what browser (Firefox & Chrome) or OS where the browser is running (Ubuntu 20.04, 22.04 and Android 12), so I am guessing that Asterisk sends the ring tone - correct?

Yet more info. Added a web-page with Java Script (Microcontroller Electronics) and things work nicely, so I’m leaning towards a thinking it’s a problem/bug with UCP phone for the versions I have installed.