UCP Phone not works

I’m trying the phone within UCP, but there’s no way to make it work, it’s disabled, you can’t press any number, and I have no errors in the freepbx log in. Some idea ?

FreePBX Gui: admin > user management > “edit user” > UCP > Phone = enabled?

Yes, enabled, also Zulu is active…all settings in user management are on

Are you accessing UCP from a domain name with LetsEncrypt https certificate installed?

I use https with a certificate issued by verisign I don’t need to use letsencrypts

Who issued it is not important as long as it’s properly configured and valid. What is important is that you are accessing UCP via a domain name using https with a valid certificate. WebRTC won’t work if you are accessing UCP via the IP address or via HTTP.

The other possibility is that you have both PJSIP and SIP installed and it is trying to use the wrong one. You would see an error from asterisk CLI saying wrong password or something like that if that were the case. I believe you need PJSIP installed for WebRTC to work. I think it can use either PJSIP or SIP but not both. I have only used PJSIP. In Settings > Advanced Settings > Force Websocket Mode, try set that to PJSIP instead of auto.

You didn’t mention anything about the status of the phone icon in the upper right of UCP. Do you see that and if so what color is it?

To clarify, the transport is neither http nor https, it is wss (secure web socket) it is generally over TCP/8089 , the issued certificate needs to be globally acceptable and accessable and any routers need to seamlessly pass such port 8089 traffic bidirectionally after successful verification.

I use pjsip only pjsip, and it’s working with Sangoma Phone Desktop and Mobile App, also with Grandstream phones. I use also olther softhone like Zoiper or MicroSip.
Extensions are registered using sips (tls) and srtp via in-sdp)

Pbx can access the internet and from the IP with which I am testing every connection is allowed in (IP Trusted - Exclueded from firewall)

The phone is visible in ucp but it is not possible to press any buttons

In Advance setting force WebSocket Mode is Pjsip

I think I found the solution, that stupid stun server!!!

I’ve always used stun.l.google.com:19302
and it doesn’t seem to have problems on other pbx, I don’t know why but changing it in stun.3cx.com in Advanced Setting–>WebRTC setting–>STUN Server Address now works

Which stun are you using out of curiosity?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.