UCP Phone - do incoming calls work?

FreePBX 16 with latest updates, P330 phones using DPMA/PJSIP. I have setup the UCP “phone” application on the UCP web portal and it works fine for outgoing calls (I am only supporting this inside our LAN). I cannot get it to work at all for incoming calls, it does not ring or show any notifications in the web browser. Tried both the latest Chrome and Edge in Windows 10 & 11.
I’ve seen older posts commenting on this issue with no answer, but are incoming calls supposed to work in the UCP phone portal? Not sure if its a setting on the browser I’m missing or something, the docs on the web are unclear so I’m not even sure how to debug this.
Any ideas are appreciated.

Are popups allowed on the browser? Does it show the phone as reachable on Reports>Asterisk Info?

Yes, popups, redirects, and audio is allowed in the browser. It shows up in asterisk info as well:
Endpoint: 9931/9931 Not in use 0 of inf
InAuth: 9931-auth/9931
Aor: 9931 1
Contact: 9931/sip:[email protected]:62458;transpor e81aa18a10 Avail 4.665

Make a call and see what Asterisk is saying.

Providing Great Debug - Support Services - Documentation (freepbx.org)

If I dial extension 31 it shows the SIP call going that that extension’s P330 but It doesn’t show anything related to the active UCP phone “9931” extension. I’m not really sure how these shadow 99xx extensions work though.
I gather from your responses it is supposed to work?

So has anyone able to get a ring notification or answer calls from their UCP phone portal?
Mainly want to make sure it is supposed to work before spending any more time on it. I realize I can use SangomaConnect for this as well, which is maybe the idea.

We have used UCP phone in the past to receive calls.

WebRTC Phone-UCP - PBX GUI - Documentation (freepbx.org)

If everything matches the wiki, you may need to reach out to Sangoma for support.

I gather you haven’t tried it on the latest FreePBX 16 then?
Those docs are pretty dated but it looks like I have everything setup. Outgoing calls work, it may be some sort of web browser security thing that prevents incoming. I know they had to switch to secure wss sockets - maybe something broke at that point. Be nice to get come confirmation that it is broken for sure. Oh well…
Thanks for your help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.