UCP Issues - Windows Server Only

We are having a strange issue with calling via UCP but only via a Windows Server machine, I did highly contemplate posting this to StackOverflow but as I suspect this to be a server configuration issue I felt it was best placed here first of all for some help and guidance.


For over a year there has been in production an Asterisk/FreePBX server which is used by agents around the globe on various Windows Desktop/Linux/MAC Machines. Rather than bothering with softphones (which require manual programming), Agents are provided with the standard UCP interface and WebPhone

The customer is starting to make a move towards RDS access for all agents onto a brand new server to give them greater control over the international users accessing their internal systems.

So, we span up a new Windows Server 2016 and proceeded to test all their applications to ensure they work in the new environment.


What we have found is that in a Windows Server environment only, calls do not progress. An agent enters the telephone number and presses call the call immeditatly fails.


As we were connecting to the server on an RDS session we then built a 2016 server locally in our offices to test, the same issue persists. We’ve then subsequently tried 2011 and 2012 and all present the same issues.

Looking at the connection logs when an agent signs in on the VoIP server we see the peer successfully register, however, when a call is placed there is no communication at all back to the server.

In fact, running a Wireshark trace on the windows server shows that no data is at all trying to be sent to the VoIP server.

We’ve, therefore (on our test machine) disabled all firewalls and anything else that could be blocking internet traffic and the issue still prevails.

We’ve also tried multiple browsers, Firefox, Chrome and Opera (Yuck) all having the same issue, the inbuilt web dev tools within these show no errors other than the call failing and terminating, the “cause” variable is flagged as “WEBRtc Error”


As this works in Windows Desktop/Linux/MAC environments without issues, we’re coming to the conclusion that this must be something related to the Windows Server environment, any suggestions would be highly appreciated.

Update After installing the user experience feature, https://voice.mozilla.org/en/listen can now be heard, the original application remains with the same issue

Which version of FreePBX? UCP?

User Control Panel
WebRTC Phone

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.