UCP is currently disabled!

“UCP is currently disabled. Please talk to your system Administrator” is the error message when trying to login to UCP.

I checked update and i saw an error message (see the attached).

How do i update certificate manager to version 14.0.8.1. The update wizard could not find update file online. Please help!!

Regards

Hi! Probable you will have to upgrade lot of modules.
Go to your CLI (ssh) and type: fwconsole ma upgradeall && fwconsole ma enable ucp
Then: fwconsole reload

I ran the command as suggested. Below is the output. Though certman was installed but UCP upgrade was stalled.

What do I do again?

[[email protected] ~]# fwconsole ma upgradeall && fwconsole ma enable ucp

locale: Cannot set LC_CTYPE to default locale: No such file or directory

No repos specified, using: [standard,commercial,extended,unsupported] from last GUI settings

Module(s) requiring upgrades: ucp

Upgrading module ‘ucp’ from 14.0.3.13 to 14.0.3.13

Downloading module ‘ucp’

Processing ucp

Verifying local module download…Verified

Extracting…Done

Download completed in 2 seconds

Detected Missing Dependency of: certman 14.0.8.1

Downloading Missing Dependency of: certman 14.0.8.1

Processing certman

Verifying local module download…Verified

Extracting…Done

Module certman successfully downloaded

Installing Missing Dependency of: certman 14.0.8.1

Updating tables certman_mapping, certman_csrs, certman_certs, certman_cas…Done

Generating CSS…Done

Installed Missing Dependency of: certman 14.0.8.1

Unable to install module ucp:

  • <strong>Certificate Manager</strong> module version 14.0.8.1 or higher is required, you have 14.0.8

Updating Hooks…Done

All upgrades completed successfully!

Updating Hooks…Done

locale: Cannot set LC_CTYPE to default locale: No such file or directory

The following error(s) occured:

  • Module ucp cannot be enabled

[[email protected] ~]# Then: fwconsole reload

-bash: Then:: command not found

[[email protected] ~]# fwconsole reload

locale: Cannot set LC_CTYPE to default locale: No such file or directory

Reloading FreePBX

Successfully reloaded

[[email protected] ~]#

Certman 14.0.8.1 is in the stable repo, so it should work. Are you able to install with:

fwconsole ma downloadinstall certman --tag 14.0.8.1

Thanks. it works.

Now i have error message on UCP - “Unable to connect to UCP node Server. Error: xhr poll error”

How do I resolve this?

Regards

what does

node -v

return ?

Unable to access the PBX at the moment. I will revert shortly.

Regards

[[email protected] ~]# node -v
v8.11.3

You are likely better off with 10, but the code is kinda temperamental so YMMV

YMMV?

What is the meaning?

Regards

YourMileageMyVary

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.