UCP Home page Keep showing connecting

I have created an extension 1001 and have also enabled UCP login for the same user. When i am logging in with user name and password , UCP keeps showing connecting… in the top header of the page.
I am not sure if I have missed something because other things in UCP seems to be fine. The message stays there indefinitely. I guess it should change to some thing else. I am logged in from zoiper for the same extension. Also i am running amportal a dbug, While logging into UCP at the home page, I get message in console dbug stating
OUT > [2016-Apr-15 01:49:42] [CRITICAL] (admin/bootstrap.php:258) - Connection attmempt to AMI failed
OUT > [2016-Apr-15 01:49:42] [CRITICAL] (admin/bootstrap.php:258) - Connection attmempt to AMI failed
Am i missing something here, or it is suppose to stay like this forever.

FREEPBX Version - 3.0.105
Asterisk Version - 13.8.0
UCP Module Version - 13.0.28

Console error -

Failed to load resource: the server responded with a status of 500 (Internal Server Error)


I’m not finding the other side of the error anywhere on the server?

Have you asked me a question or you are facing the same sort of issue. I have read some documentation, I guess it is looking for UCPNODE server which is not available in non distro installation without fee. Ideally it should time out and say UCP is running in offline mode.

However it stays forever saying connecting. I am not sure what AMI connection it is looking for. My FreePBX GUI works fine and is able to connect to asterisk via AMI. It is only UCP showing this message. i had FreePBX 12 with UCP, it does not say any thing like this. So my assumption is either it is something to do with UCP code or there is something terribly wrong with UCP GUI which I am sure what it is.

Sorry, I intended to post that on the thread “ucp going offline on safari”

UCPNODE is free. There is NO cost. It’s only in the distro.

That being said it’s not your issue. It won’t look for it if it’s not installed. You have something else going on.

You’ve already posted the error. You have an AMI connection error. The UCP code is fine.

Where else i can check this, I have tried removing and installing UCP module twice however message remains same. Is there specific AMI settings for UCP module, does it not use the same AMI user and password which is used by FREEPBX gui.

I have tried disabling IPTABLES and SELINUX is also running in permissive mode. Can you give me any pointers, where to look for. Though i am trying to find what is causing this.

I think I have figured out what was causing this. It is the presence module which is responsible for that message in the top header. I am not sure why, what it was looking for. When I removed presence module, message went away.

Don’t you think that message would have been something else, Error message about not able to AMI was misleading. There was not AMI connection issue at all. Anyways thanx for your response.