UCP and Zulu Remote Access

pbxact
ucp
Tags: #<Tag:0x00007f702ad98568> #<Tag:0x00007f702ad981d0>

(Bryce Holland) #1

I have read many forum posts about accessing the UCP interface remotely, however they either do not have a solution, or they do not quite match what I am experiencing. I will do my best to be as detailed and specific as possible.

  • Appliance: PBXAct 100 running version 14.0.13.12
  • Interface: set to the default Internet Zone
  • RapidSSL certificate installed

With the following settings:

  • UCP: enabled for the Internet, Local, and Other zones
  • Web Management: enabled for only the Local zone.
    The Admin UI is not accessible remotely, however UCP is also not accessible. The Zulu desktop app logs in, however fails with any calls with a “connecting” error.

With the following change:

  • Web Management: enabled for the Internet and Local zones
    BOTH the Admin and UCP UIs are accessible. The Zulu desktop app also signs in and successfully sends and receives calls.
    Obviously there is a significant security problem. I DO NOT want the admin UI accessible from the “Internet” zone! However, disabling that zone for the Web Management (Secure) also causes UCP to be inaccessible and Zulu to not connect for calls.

Yes, I do have the documented Zulu and WebRTC ports forwarded on my firewall, however there must be something else required that is not in the wiki documentation.

Any thoughts or ideas? Yes, I did try to access the UCP web UI above via https://fqdn/ucp and https://fqdn:4443 with the same results.


(Lorne Gaetz) #2

Admin, System Admin, Port Management. There are options there to set a port specifically for UCP for both http and https. Using those ports you can browse to UCP with:

http(s)://address:port

where the port is the specified UCP port. If that doesn’t work as expected, open a PBXact ticket.


(Bryce Holland) #3

Igaetz,

Thank you for your reply. I did setup those ports from the very beginning.
Fortunately, for the UCP UI, the solution was silly (helps to step away for a minute and then try again). I already had port 4443 forwarded to a different server on my firewall, so changing the port for UCP resolved that issue. I won’t know if the Zulu desktop app works until I can try again later.


(Lorne Gaetz) #4

I can’t see how Zulu would be affected in any way by the PBX Firewall settings for the Admin GUI, unless you are also making changes to the white list at the same time.