I keep on losing my registration with braodVoice, and their support tells me it is my PBX’s fault. I just lost the connection (could not call myself, got “party cannot be reached” announcement. I changed to a different proxy server of theirs, ran “sip reload”, and presto, I am connected again. Of course that is not a viable solution, as I am not in the habit of calling myself every 5 minutes to see if my line is still connected. So I am trying to get to the bottom of this. I am behind a NAT, but I have opened the ports that are supposed to be opened, and forwarded what needs to be forwarded. and the system does stay connected for hours before it drops out. I don’t think it is the NAT’s fault.

Now, when I look at the log, I see a warning after I reset the connection:

chan_sip.c: Section ‘XXXXXXXXXX’ lacks type (where XXX is my phone number).

I do have type=peer in the peer section of the trunk. Why does it tell me that there is no type, and could this be related to the problem I have?

  1. Are you defining the user section by any chance ? Do not do that.

  2. To keep NAT alive use qualify=yes.

No, nothing in the user section.

I have nat=yes in the peer section. Will add qualify=yes and see if it helps.


nat=yes is wrong, you should never use that. it should be nat=no or nat=route/nat=comedia (asterisk 1.8 changed the name route to comedia)

Can you show output from

grep -A 8 \[XXXXXXXXXX\] /etc/asterisk/sip*.conf

Isn’t this the fifth separate post you’ve made on this one issue?

I tried Broadvoice ten years ago and dumped them because of technical issues and non-existent customer service.

Have you tried another provider yet?

Possibly (5th post). I have now signed up with another provider (Flowroute) and while my Broadvoice trunk has unregistered again, the flowroute trunk is happily churning away. I’ll keep an eye on it, but for now it seems OK. Hopefully this will take the who issue to rest.

I am having one issue with flowroute: When I dial a local number (10 digit), it doesn’t connect. When I dial the same number as an 11 digit number (1-XXXXXXXXXX) it works. I suppose that Flowroute expects an 11 digit number and I have to find a way to make sure that the numbers dialed have 11 digits. Any help on this? (I did a cursory search of the forum, but didn’t find anything).

Come to think about this, I think I will repost the above issue in it’s own thread. I don’t want to bury it too deep in this one. Please respond to the tread “11-number dialing” instead here. Thanks.