Two trunks to the same provider on one machine, but one up, one down? Need 2 up


#1

I have two trunks, one for each group. One trunk is up, and calls work like normal. The other appears to be down (one is listed as down on the Dashboard), and the other group cant call out. I checked Class of Service, and the extensions are split appropriately. The one that doesn’t work gets an “all circuits are busy” message. But the trunk provider says both are registered (and recently). So on their end it looks like both are up.
I do get the following in the logs:
[2019-10-22 03:26:53] ERROR[7385] netsock2.c: getaddrinfo(“provider ip address”, “(null)”, …): Name or service not known
[2019-10-22 03:26:53] WARNING[7385] acl.c: Unable to lookup ‘provider ip address

I’m nut sure where that is pulling from though. Looks like a bad entry is left over, but not sure from what or where. The server can resolve the hostnames that the trunks use (they are on two different servers at the same provider).

sip show peers give me:
VOIPms-GIG/111111 (Unspecified) Yes Yes 0 UNKNOWN
VOIPms_GSK/222221 23.29.136.28 Yes Yes 5060 OK (3 ms)

The configurations for the two trunks are identical for both save the server, name and password.


(David55) #2

This sort of configuration can confuse providers even with different names. With the same name, it is almost certain that the provider will not be able to tell them apart.

Why can’t you have one trunk with twice the capacity?


(Jared Busch) #3

Since you’re using VoIP.ms, put the other trunk on a different PoP. Also make sure each truck is registered with a different sub account.


(Tom Ray) #4

This has nothing to do with the other side. This has to do with Asterisk not being able to lookup that host= details for the trunk. It’s not even attempting to send the request out. So changing POPs may fix it but then it also requires you to change the host= setting at that point too.


(Dave Burgess) #5

Don’t ask me why, but check for commas.


#6

So I deleted and re-setup the trunks again and now it’s all good. They are on two separate accounts (separate billing) and pointed to separate PoPs so it shouldn’t have been any different than using two different providers. I think it was just the config didn’t get written properly for some reason. Where does the Trunk configuration lie, if I were to go look for it (though it’s moot now)? I am going to add a backup provider, and now that I think about it, just adding a second trunk to a different PoP on voip.ms wouldn’t be a terrible idea.


#7

On VOIP.MS make sure you set a failover number (this would be your second trunk). Also for the second trunk set the number (at VOIP.MS) to the primary trunk number this way if you call out users will see your primary number not your backup trunk number. : )


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.