Two NICs -- One is configured with Local Lan and Second will be P2P to my Local Service Provider

configuration
Tags: #<Tag:0x00007fafc2e822a8>

(FAK) #1

hi Guys,

I have a pbx running with one NIC which is configured in a way that it’s on Private Lan and gateway is my Internet Firewall so all my carriers like FR, SR are configured properly on this network card.

However Now I have to add another card with IP scheme from My other Sip provider P2P.

This provider has provided me with bunch of ip addresses and gateway and Sip Proxy.

I have to configure the network card with it’s ip address and gateway then I will be able to reach out to this Sip Provider network to make sip trunk.

Scenario is Internet Firewall gateway is for All the international Traffic or Trunks with International providers and this second interface with P2P network my end users can dial Local Calling to my country.

Now I need to add the second Nic with gateway and subnetmask and it should be accessible from the phones on the private network.

Please guide me.


#2

You add the second NIC and configure a static route to your new P2P provider through the new NIC.

Yo can look for specific instructions on the internet on how to add static routes for RedHat 7.


(FAK) #3

I have tried to configure the nic from Freepbx System admin but unfortunately it configured the eth1 and it’s now updating the ip address scheme on this nic however I have also removed this but it’s still showing in the ifconfig and when I locate the eth1 , it gives me these destinations
/dev/.udev/db/net:eth1
/etc/sysconfig/networking/devices/ifcfg-eth1:1
/etc/sysconfig/networking/profiles/default/ifcfg-eth1:1

Output:
cat /dev/.udev/db/net:eth1
E:NET_MATCHID=

cat /etc/sysconfig/networking/devices/ifcfg-eth1:1
cat: /etc/sysconfig/networking/devices/ifcfg-eth1:1: No such file or directory


cat /etc/sysconfig/networking/profiles/default/ifcfg-eth1:1
cat: /etc/sysconfig/networking/profiles/default/ifcfg-eth1:1: No such file or directory

I have unconfigured it from the GUI system admin -> network settings but it’s still showing as configured and when i rebooted the system it still there

How do I get rid of this.


#4

Static routes can’t be configured from the GUI.
Also, there shouldn’t be a : on the NIC name.
You are probably better starting again with a clean config.


(FAK) #5

it’s not static route.
it’s network adapter configuration.


#6

You should see both NICs on the GUI as long as the drivers are loaded.


(FAK) #7

| | __ ___ | _ | __ ) / /
| |
| '
/ _ / _ \ |
) | _ \ /
| || | | __/ __/ __/| |) / \
|
| |
| _|_|| |__//_\

Interface eth0 IP: 172.16.10.30
Interface eth1 IP: 172.16.10.30

this is what I come up with on bootup

eth0 Link encap:Ethernet HWaddr 00:15:5D:0A:9D:04
inet addr:172.16.10.30 Bcast:172.16.255.255 Mask:255.255.0.0
inet6 addr: fe80::215:5dff:fe0a:9d04/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:36303 errors:0 dropped:0 overruns:0 frame:0
TX packets:5347 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5832611 (5.5 MiB) TX bytes:2076115 (1.9 MiB)

eth1 Link encap:Ethernet HWaddr 00:15:5D:0A:9D:0B
inet addr:172.16.10.30 Bcast:172.16.255.255 Mask:255.255.0.0
inet6 addr: fe80::215:5dff:fe0a:9d0b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:13 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2553 (2.4 KiB) TX bytes:468 (468.0 b)

both eth showing same ip but

ls /etc/sysconfig/network-scripts/

ifcfg-eth0 ifcfg-lo ifdown-bnep ifdown-ippp ifdown-isdn ifdown-ppp ifdown-sit ifup ifup-bnep ifup-hdlc ifup-ipv6 ifup-plip ifup-post ifup-routes ifup-tunnel init.ipv6-global network-functions
ifcfg-eth0.back ifdown ifdown-eth ifdown-ipv6 ifdown-post ifdown-routes ifdown-tunnel ifup-aliases ifup-eth ifup-ippp ifup-isdn ifup-plusb ifup-ppp ifup-sit ifup-wireless net.hotplug network-functions-ipv6


#8

There is definitely a mistake there. You can’t have the same IP in two different NICs. Correct that by editing either ifcfg-eth0 or ifcfg-eth1.


(FAK) #9

there is no ifcfg-eth1


#10

Then your configuration is severely flawed.