Two NICs - External Audio issue


(City It Guy) #1

I have a FreePBX install (14.0.13.23) with two nics. One NIC sits on my LAN with an IP of 10.0.0.30. This is the nic that has access to the Internet through a firewall (sonicwall) and is the one that is accessible from workstations on the LAN for management purposes. The second NIC has an IP of 10.0.1.1. All of my phones are on this network, pointing to the Asterisk box as the gateway, and there is no access to the Internet on this network. If I make internal calls extension to extension, I have no audio issues. When I make or receive external calls, I have no audio on the call. I would suspect the issue is related to the call not correctly routing from the firewall, through the FreePBX server on NIC 0 and then back out NIC 1 to the telephones, however I have searched the forums high and low and cannot documentation showing what I might have wrong.


#2

Confirm that your SonicWALL is properly set up:

In Asterisk SIP Settings, confirm that Local Networks and External Address are properly set.

If you still have trouble, post a log of a failing call, including SIP trace. At the Asterisk command prompt, type
pjsip set logger on
for a pjsip trunk or
sip set debug on
for a chan_sip trunk, then make your test call.

Also, on an outbound call, report whether the remote party can hear the caller.
On an incoming call that goes to voicemail (or an IVR), does the caller hear audio?


(City It Guy) #3

I’m pretty sure that I have the sonicwall configured correctly. I just recently configured a sonicwall to work with an eMetrotel (based on freepbx) box, and I used the same settings for this box. I really think the issue has something to do with the call not routing correctly between the two nics. Right now I have no audio either way on incoming and outgoing calls. I tried to post the log file but I keep getting an error that I can’t post links and I can’t figure out how to get around that with my log file???


#4

Seems unlikely, but possible. So (for example) incoming calls routed to an IVR work fine, until the call is sent to an extension. Or, incoming calls that go to voicemail are ok. Or, incoming calls forwarded to a mobile phone are ok. Is that correct?

Make a failing test call (with SIP trace). View the log at Reports -> Asterisk Logfiles. Redact as desired and paste it at https://pastebin.freepbx.org

Try to post the link here. If you have trouble, replace the last dot with %2E for example
https://pastebin.freepbx%2Eorg/view/2c069bda
which can be pasted into a browser address bar and it will function as a link.

Confirm that your SonicWALL has a public IPv4 address on its WAN interface. If not, please explain (ISP supplied a gateway configured as a router, ISP does NAT, etc.)

Also confirm that if the PBX is on a virtual machine, the VM is set for bridged networking.


(City It Guy) #5

Thanks for the tip on the paste bin. Here is the link:
https://pastebin.freepbx.org/view/e9d29cf7

The SonicWall does have a public IP provided by the ISP. I have disabled SIP Alg, made sure that consistent NAT is enabled under the VOIP settings. I’ve made sure that Multicast support is enabled on both the WAN and LAN, and I’ve added firewall access rules from my SIP provider (WAN) to the PBX (Lan).

The FreePBX is not a VM, it is installed as the primary OS.


(Lorne Gaetz) #6

If you haven’t already done so, in Settings -> Asterisk SIP Settings, you want a local network set to 10.0.0.0/8 and the external IP set to whatever the WAN IP of the router is. In chan_sip, set NAT=yes and Static IP.


#7

It appears that UniTel sent audio from their upstream ANI Networks. See line 302 of log.
So, be sure that your firewall rule for UDP ports 10000-19999 forwards packets from any source IP address to 10.0.0.30.

Also, based on the rport value on line 260, it appears that you did not set Disable Source Port Remap for one or more of the policies. Please revisit the Happiness with Sonicwalls link and confirm that you have performed all the steps correctly.

If you still have trouble, we can do a tcpdump capture to look at RTP coming in and going out.


(City It Guy) #8

I missed the Disable Source Port Remap on the policies. I’ve enabled that and I now have audio in both directions on outgoing calls. I’ve got to wait on the number to port before I can test incoming calls. Hopefully they will work as well. Thank you so much for the help!!!


#9

I know nothing about UniTel, but with most providers you can purchase a number on their portal and it’s available instantly. They may hit you for a small setup charge and a one month minimum, but the total is probably less than $5 and a worthwhile investment so you can configure and troubleshoot incoming before your number ports. Also, if whatever you’re porting from has call forwarding, you can forward to the temporary number and have the whole system live. With luck, you won’t lose any calls during the porting process.


(Lorne Gaetz) #10

A free SIPStation trial will get you a DID and some minutes for testing as well.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.