Two IP Addresses Configured?

When I log in to the FreePBX Linux console, it shows the server has two IP addresses - x.x.x.2 and x.x.x.20. As far as I understand, everything is using the x.x.x.2. Router ports are forwarded to x.x.x.2.

Is this an issue? If so, how do I remove the x.x.x.20 IP address?

The System Admin only shows one address:

It is not a WiFi address:


There is a response when I ping x.x.x.20 from my PC. But I don’t know exactly what is responding.

We do have an ongoing issue where our SIP provider endpoints are constantly going Reachable/Unreachable/Reachable/Unreachable. So I’m going through everything I can think of and came across this. We don’t need to try and troubleshoot that issue here, unless you think they might be connected.


By default you should have only one IP on the interface. Maybe you have assigned two IPs? Check the ifcfg script for your eth0 located on /etc/sysconfig/network-scripts/ifcfg-eth0

Here is what I get for ifcfg-eth0:


Here is what I get for ifcfg-eth1:


Any thoughts about this? Thanks.

Check what is shown by

ls -l /etc/sysconfig/network-scripts/ifcfg*

maybe you have a vlan setup or some other network on eth0

Here is that result:


The whole switch serving all phones and the FreePBX server are on a VLAN given by the gateway/router:

Any ideas with that? Thanks.

Your issue is that ifcfg-eth1 has DEVICE=eth0 so in addition to the static IP defined in ifcfg-eth0, eth0 is also getting a dynamic IP through ifcfg-eth1


So does ifcfg-eth1 need to have “DEVICE=eth1” and “NAME=eth1”?
Or maybe would “ONBOOT=no” turn off eth1 so there is no conflict?


I have found this second x.x.x.20 IP address in the Firewall → Interfaces screen:

Does this look right?

Does your server have two NIC cards? If so, do you need both? If you only need eth0, set onboot=0 for eth1 but also make sure to set device=eth1. You need to fix the device parameter in any case.

1 Like

Thanks for assisting.

The server actually has four Ethernet ports. We are only using one for this FreePBX server.

For eth1 in the ifcfg-eth1 file, I set the following:

Now when I log in to the console it only shows the one server IP address, x.x.x.20 no longer responds to a ping, and the additional interface does not show up in Firewall -> Interfaces.

@arielgrin Thank you for the assistance!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.