Tutorial for RaspberryPi 4 Installation


I tried to figure out with this tutorial:
“r30661088-PBX-FreePBX-for-the-Raspberry-Pi#google_vignette” from the dslreports(.)com Forum

But after the reboot (before “GVSIP”) nothing more happens, so I don’t know what I should do now…

I want to use my RaspberryPi 4 Model B as an accesspoint to use my smartphone (in the WiFi) as VoIP-Phone with the VoIP-Account of my ISP.

Is ther someone who could help me getting this working?

greets DL2ROY


thx for the answer but it seems not to work…

I checked this and I can’T use this commands…
All the commands they say in this tutorial don’t work for me “command not found”

List of RasPBX specific commands:
raspbx-upgrade      Keep your system up to date with the latest add-ons and
                    security fixes
configure-timezone  Set timezone for both system and PHP
install-fax         Install HylaFAX                          
add-fax-extension   Add additional fax extension for use with HylaFAX
install-fail2ban    Install Fail2Ban for additional security
install-dongle      Install GSM/3G calling capability with chan_dongle
raspbx-backup       Backup your complete system to an image file

Also the “nextsteps” don’t work, because they show to use the Web GUI, but when i try to use the web gui, it shows only the “Apache 2 Debian Default Page”, so no Web GUI…

What could I do there?

After ssh-login it shows this:

login as: root
[email protected]'s password:
Linux FreePBX 5.15.84-v8+ #1613 SMP PREEMPT Thu Jan 5 12:03:08 GMT 2023 aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Feb 24 18:15:27 2023 from

Wi-Fi is currently blocked by rfkill.
Use raspi-config to set the country before use.

greets DL2ROY

I recommend installing raspbx from the website I provided.

Ok, so I try to install it from new…

so, actually I dropped the .img from the official Site (like in your tut) on my sd card, but the pi don’t comes online… So unable to connect on ssh or whatever…

To install the .img on the card, I used “Win32DiskImager”. That should work, it worked with all the other images I ever instaled on my Pi’s…

@mahbell any idea what I could do?
I installed the actual img which is the same as you said, the 10.10.2020, with Win32DiskImager on my SD-Card which is an 64GB SanDisc ultra whatever…

The Pi has the red LED on and the green LED is flashing sometimes for some seconds (4x slow and 4x fast)… The LAN-port only has the orange Light on. In my Router “Clienttable” the Pi is not listed, so not online…

Did you vrryfy the checksum of your image against the published expected one?

And the monitor connected to the Pi shows?

Hello thx for the answers,

@dicko : no. how can I do this?
@Stewart1 : actually there is no monitor connected, the tutorial says to connect per ssh, that’s why i didn’t connect a monitor… I will check this tomorrow morning…


Shows the sha1 checksum of whatever
So to check

sha1sum raspbx-10-10-2020.zip

Then unzip it and ‘dd’ it to the card

Hi, thx for the reply.

I use Win10, does this command (sha1sum) work on windows?

No ide, it would on it’s Linux subsystem though.
Try googling ‘sha1sum windows’

Good Morning,

This is what I get when I connect a screen…

EDIT: @dicko sha-1 seems good…

The page at Downloads | Asterisk for Raspberry Pi says “Due to personal reasons it is unfortunately currently not possible to update the original RasPBX again in order to support the latest Pi 4 hardware revisions.” and more specifically says “Pi 4 with 8GB RAM hangs when running the upgrades.”

So, if you have a smaller or older Pi, try that. Or, you may be able to fix the source. Or, you may be able to start from an OS that does run well on your Pi and rig your own script to install Asterisk, FreePBX and whatever other packages such as fail2ban that you want.

Or, give up and run your PBX in the cloud or in a VM on some other system you have always on.

that’s why i used the Tutorial from the offical Download page (raspberry-asterisk .org/downloads/) which is this one:
dslreports .com/forum/r30661088-PBX-FreePBX-for-the-Raspberry-Pi

But there I got the Problem that the Web GUI didn’t work…
FreePBX was installed and “started” but instead of the Web GUI i got an Apache2 default page…

You might be better off using the official forum for that software.

1 Like


in this forum I don’t even get a reaction.

Actually i tried a bit…
it seems that everything is running, but the web gui is still not available, or at least i only can see the apache default page…

root 507 0.6 0.2 396924 19372 ? Ssl 14:12 0:00 /usr/bin/python3 /usr/bin/fail2ban-server -xf start
mysql 599 0.4 1.1 1647588 88700 ? Ssl 14:12 0:00 /usr/sbin/mariadbd
root 600 0.1 0.3 161324 31964 ? Ss 14:12 0:00 /usr/sbin/apache2 -k start
asterisk 768 3.5 0.9 2268380 75112 ? Ssl 14:12 0:03 /usr/sbin/asterisk -g -f -p -U asterisk
asterisk 772 0.0 0.0 1808 424 ? S 14:12 0:00 astcanary /var/run/asterisk/alt.asterisk.canary.tweet.tweet
avahi 386 0.0 0.0 7072 2696 ? Ss 14:12 0:00 avahi-daemon: running [FreePBX.local]

I don’t know whether this applies to a Pi, but on a CentOS-based FreePBX, the document root is
and you should see an index.php there, as well as an admin directory.

If the stuff is there, check why the Apache config isn’t referencing it.
If it’s not there, search for index.php to see where it got put.
If index.php doesn’t exist anywhere, the FreePBX install probably bombed out early; if you don’t have the logs, attempting a re-install with luck will show an obvious error that points to the problem.

Hi @Stewart1
Thx for the reply.
It already helped a lot… .

I found this:

[email protected]:/var/www/html# dir
admin index.html index.php robots.txt

So i moved index.html to index.html.old to get direct access to index.php
Now, when i try to go to http://freepbx.local it refers to this:


But it is still not working corectly… This page shows this: