Turn off trunk for a period of time

My SIP providers router/server software seems to get annoyed when my PBX wants to establish too many connections too fast when the PBX comes up before the router. I’ve not had phone services, I’ve just noticed, for the last couple of days. I don’t get phone calls all that often so, I’m not overly concerned.

What I’d like to be able to do is run a command that will turn off all services for a period of time (Other than SSH) and then start everything back up. As it stands now, I turn the entire machine off, wait for however long I need, then turn it back on. Its a VM.

Can anyone provide me with a series of commands that’ll effectively turn the software off, or at least stop trying to connect to the SIP server? I’m linux saavy, but PBX/Asterisk noob.

Starting and stopping Asterisk without using amportal script can cause Asterisk to run as root.

Disregard, I guess. I used: [ service asterisk stop ] waited for a few, then [ service asterisk start ]. Seemed to do the trick. Now to have something babysit the log file.

Thanks. Just what I was looking for. I’ve gotta update my motd on that machine with that command since this is something I don’t do that often.

Double-post since I don’t seem to be able to edit.

sip:1519{myphone}@;transport=UDP FPBX-2.9.0( 2013-06-22 07:35:24 2013-06-22 07:45:24 600

They’re complaining about that 600, but no I don’t see anywhere in my config via the web interface for freepbx a 600. I’ve checked the trunk, checked the routes, checked the sip settings, and nothing.

Ideas? I’m going to poke around at some of the configs, so might turn out to be a tripple post.

I don’t even know what that line of information is. Nothing out of FreePBX. Whatever that is it’s picking up the user agent.

I found out that my PAP box wasn’t working properly. The full log was reporting that it couldn’t find a proper codec. Even turning on all codecs, it still wouldn’t accept it. Fortunately, before my issues started, I had backed up the PBX OS (Its a virtual machine, so exported as an appliance) and put it back into place. Reconfigured everything, and now they’re happy. Ticket closed, I can forget about this nightmare. :stuck_out_tongue: