Trying to register SIP phones

I have just loaded Trixbox onto a new PC and it has been allocated an IP address of by the DHCP.

I have 2 x SAFECOM SIP3000 phones and X-LITE on my laptop.

I have set up SIP extensions in FreePBX both with and without secrets and tried to get the phones (Extensions 101, 102 and 103) to register with the FreePBX so that I can initially achieve communication between the phones via the exchange.

This is my first attempt at this and I am completely lost and out in the cold. Any help would be much appreciated.

Hi John

Welcome to the world of Freepbx.

A few things which I would suggest, One to change the ip of your PBX to a static address, as if the ip is reasigned then your sip phones will not know where to connect to.

This is simple to do, Log in to the box via terminal or putty

at the command prompt type setup

go to the network configuration and put in a ip address that is outside the scope of your dhcp server but on the same subnet, also ensure you put in the gateway and netmask and dont forget dns server as you will need this to resolve for system updates.

after you have done this exit out of the config editor, and type /etc/init.d/network restart

you will now have to log into the box if on a putty session on its new ip.

to get your sip phones to work use the following config the ip address of the asterisk server, your ip phone will have to get a ip and gateway address but you can allow your dhcp server to do this.

ensure that you include the IP address of asterisk as the registrant address port 5060 is normally used for sip and dont forget to include a password.

Ensure your sip config had the phone no + password configured, dont worry about email or any other settings for the moment.

if you are unsure that you phones are registered, you can normally see them from your web interface, But to be certain, log into the terminal on the console or via putty

type asterisk -rvvvvvv

type sip show peers

this will show you any sip clients that are registered.

Hope this helps

Oh BTW make sure when you do config changes that you apply the changes with the apply changes bar.



Thanks for your response. I have successfully managed to set my server IP address to

When I did this, however, the web interface to trixbox changed language to French.

An interesting side effect to changing IP address I thought!!

I have then changed my 3 phones to be extensions 201, 202 and 203 with secrets of 201, 202 and 203 respectively.

The 2 safecom 3000 sip phones are registered using DHCP and have been allocated IP addresses of (extesnsion 201) and (extension 202).

I then entered the secrets into the sip phones and rebooted them.

I also set up the parameters for extension 203 with password 203 on the X-LITE on my laptop.

I set the following parameters in the X-LITE:-
Display name: Test203
User Name: 203
Password: 203
Authorization user name: 203

Use local IP address
Use specified server:
Enable ICE
X-Tunnels never

I get the error ‘Registration error - 404 - not found’

Having checked the SIP peers, there are none registered.

I do not understand???