Trying to enable sip tls and srtp, FreePBX 13 and Grandstream..need help

i would like to enable both sip tls and srtp on my FreePBX 13 install (patched current). i found this wiki article and followed it. I regenerated the config files for my phones (grandstream), but when I look at the files, i still see

# SIP Server
P402 =

5060 is the port for normal sip. elsewhere in the config, TLS is turned off

# SIP Transport. 0 - UDP, 1 - TCP, 2 - TCP/TLS
P448 = 0

so, has anyone got this working? is this an endpoint manager issue?

thanks for your help!

Those settings only work with Sangoma Phones. That wiki is on Sangoma Phones.

I have SIP over TLS and SRTP working with Grandstresm endpoints but not using EPM.

ug, sorry, i see that now…is there any docs on how to do this generally? if the extension is set to use tls, why does EPM not generate the config with the right port etc?


hi, did you configure the phones manually?

Yes. I followed the wiki for chan_sip.

At this time EPM only ties into extensions for SRTP and TLS for Sangoma phones. All other brands in EPM are basic features only with Sangoma Phones having the tighter integration for things like this and codecs.

Am I correct by stating, EPM only supports those features natively for sangoma phones however EPM provides us the ability to customize the base file which provides total control for these settings to be entered and automatically provisioned.

Tony, while I do appreciate that i can edit the base file in EPM, i feel like this is disappointing news. the EPM compatibility guide lists these grandstream phones (and others) as being “certified” devices. I feel like if the device is certified, it should support most/all of the functionality in the gui.

you say “at this time”… is there a roadmap for tls support for non sangoma devices ?


Unfortunately EPM does basic features for non Sangoma Phones and this is not going to change.