Trying to connect T46G to remote hosted FreePBX

I have been trying to connect a Yealink T46G to a remote hosted FreePBX install.
I was able to connect setting everything up manually through the phone’s web GUI but decided to spend the money and buy EPM so we could push changes, etc out to remotely connected users phones.

I cannot get the phones to auto provision using EPM. I have tried disconnecting the server firewall and also the FreePBX responsive firewall and still nothing.!

PBX Version:
PBX Distro: 12.7.8-2104-1.sng7
Asterisk Version: 17.9.3

I messed with EPM and my T46G for a while a fee months back. I had to put the server address and UDP port in the phone gui and then it provisioned no problem with EPM.

  1. You cannot use https with an IP address you Ned to use the FQDN.
  2. The T46G does not understand the SSL certificate used by FreePBX 14 and 15. You have to modify the script before you get the cert.
  3. A phone has to be told how to reach the phone system by something after power up. Typically, you set up DHCP option 66 for this.

So I’ve set the provisioning to http instead of https to test it and also set the FreePBX server address in the auto provision section of the phone GUI and tried to auto provision and still get nothing.
Option 66 only works if the phone and the server are on the same network doesn’t it? The phone and the server here are remote.

Not at all how things work.

Not at all how things work.

Ok. As you can probably tell, I’m totally new to all of this but using option 66 means that the user would need to change configuration of their router wouldn’t it?

See I was hoping to make it easy enough for someone to be able to take the phone home and plug it into their home router to work from home but still be connected on the office phone system?
I paid for the EPM module thinking that it would be a easy solution if we did need to update anything on the phone configuration we could then just push that through to the remote phones.

Once provisioned the first time, yes you can do this.

But you cannot reset a phone or drop ship an unconfigured phone.

I have an account with 888voip and because of this I was able to get a remote provisioning account for Yealink phones that would give you the ability to dropship phones and allow remote configuration (assuming you already have the external ip and add it to the firewall)

I use http for my yealink provisioning. With the blurring its hard to see if you have the port numbers on the end of the ip address for the config

No I haven’t added any port numbers. Where should I be adding them?

You always need to include port numbers when doing provisioning otherwise, it assumes by default you’re using port 80, which you aren’t.

Here is an example of my Endpoint manager with Yealink

You’d use something similar on the yealink phone itself for the auto-provisioning, assuming the mac and templates are correct in EPM.

That got it.

Thank you

That is not how EPM works. It knows what ports you are using and creates the file correctly. There is no reason to use a custom URL.



Once you map an extension, you can look at it in /tftpboot and copy that to a phone manually for initial configuration.

I am assuming he used the port on his yealink phone, which you would need, in the GUI.

Good to know about EPM though.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.