Trying QXact Reports but no queues or agent show to select

Installed the trial of QXact Reports and trying to create a report. However, no Queues or agents show up in the corresponding input selections, and we have 3 Queues and 20-some agents.

The records used to Generate QXact reports begin when the module is licensed. Dido you have a history of queue records at the time of the test?

Good Question. The trial shows activated on 2/3. We had agents working on 2/4. I tested today but still no ques or agents showing up. I’ll test again at the end of day 2/6

Call Recording Report Expiration Date 2045-04-14 (Free Updates until 2021-04-14)
Endpoint Manager Expiration Date 2045-03-26 (Free Updates until 2024-03-25)
QXact Reports Expiration Date 2023-03-03
Sys Admin Expiration Date 2045-03-26
VM-Notify Expiration Date 2045-04-14 (Free Updates until 2021-04-14)
Voicemail Reports Expiration Date 2045-04-14 (Free Updates until 2021-04-14)
VQ Plus Expiration Date 2023-03-03
Zulu Expiration Date 2023-03-21 (Free Updates until 2023-03-21)
Zulu Users 20

And in Module Admin:
Commercial Status: Licensed

Still no queues or users populating. The module has been activated since 2/3.

From ssh, try fwconsole reload or fwconsole reset if you can. Note reset will bring down Asterisk for 1-2 minutes.

Why is the post hidden from the community?

I’ll try it this evening after hours - Can’t bring Asterisk down while 20 agents are making calls :slight_smile:

1 Like

No go :frowning: fwconsole reload didn’t change anything. fwconsole reset returned an error “command reset is not defined”

Still no ques or users showing up in Que Reports.

Also tried fwconsole restart. All services restarted and running, but still no queue reports queues or users.

What does the queue look like under Report>Asterisk Info> Queues? Does the info show there?

One thing you might be able to try is to uninstall and re install the module

Another check you could do is while logged in to your PBX as root (ssh), do:

select count(*) from asterisk.qxact_calls;

If you are not seeing records, there you will likely need to open a support ticket to resolve.

Ques and agents show up under Report>Asterisk Info> Queues

But nothing when searching mysql

I’m trying to connect to support but it just takes me around in circles - LOL. I’ve seen better user interfaces :slight_smile:

I noticed there are no call statistics on the Asterisk Info>Queue page you shared. Just to confirm, have there been queue + agent calls? If not, then the logs will not populate and there will be no data.

There have been calls, although not since 5PM on the 7th. I ran the check around midnight (12am the 8th). The IVR sends the vast majority of inbound calls to the main queue.

1 Like

Then support ticket is likely the best bet. When it gets it resolved for you, remember to share back here for future readers.

The new support system is not working. I started by logging in to the old system which directed me to the new system, which said I needed to validate my email addrsess. Sent the validation email, clicked on the link and got an “error our technicians are working on it” message. I’ll try calling tomorrow.

BTW, the reason there were no calls in the queues when I checked is because its set to reset the stats every day at 23:59 - LOL. I checked a little after midnight.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.