Trying PJSIP no audio on endpoints

Hello Everyone!

Our setup: We have our server behind a SonicWALL in our data center, ports 5060 10000-20000 is allowed from our offices and from our SIP provider, ports for provisioning and GUI management is allowed from our offices only.

Since PJSIP allows more than one device per extension we decided to try using it, so i enabled the PJSIP driver, set the port to 5062, allowed on the SonicWALL port 5062 from our offices, i was able to register two devices to one extension (201) and a third device to a second extension (202), when i call 201 from 202 it rings both devices but no audio and the call terminates after about 30-32 seconds.

I tried enabling ICE support in the extension settings but it did not help.

Can anyone that has PJSIP remote extensions working please guide me how to set this up?

Again, we currently have many CHANSIP extensions working at our offices no problem, the issue is only with PJSIP.

Thanks for any help.

Check NAT settings under PJSIP settings. I cannot remember what i did but there was an issue with local networks and NAT settings and as soon as I changed that PJSIP starting passing audio and the 31 second rtp dropped calls started working.

I don’t have any NAT settings in the PJSIP tab.

Try adding the phone network as a local network under declaration.

Tried that, also added our WAN IP. did not solve this.


Watch asterisk. What error do you see when you try to make a call.

I had a sipsettings update, i updated restarted asterisk and it’s working fine now…

also i removed our WAN IP and local IP from that section, restarted again, still works…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.