Trying iSymphony

I’m testing

FreePBX Distro 6.12.65-26
Asterisk (Ver. 13.2.0)

At first iSymphony server was not running and it was required to start it from console with:

service iSymphonyServerV3 start

Now I can login to the administrator panel and I can login with a user extension but I can’t make calls and the extension display “Avaible” when they are not. When I make a call I get this message in a pop-up window.

Failed to handle call back voicemail

com.xmlnamespace.panel.lib.pbx.request.ActionException: Extension does not have a bound device
	at com.xmlnamespace.panel.server.core.asterisk.action.OriginateActionHandler.getAsteriskPeerFromExtension(
	at com.xmlnamespace.panel.server.core.asterisk.action.OriginateActionHandler.originateToDestination(
	at com.xmlnamespace.panel.server.core.asterisk.action.OriginateActionHandler.handle(
	at com.xmlnamespace.panel.server.core.asterisk.action.OriginateActionHandler.handle(
	at com.xmlnamespace.panel.server.core.asterisk.action.ActionHandler.handleRequest(
	at com.xmlnamespace.panel.lib.communication.request.manager.RequestTopicManager.handleRequest(
	at com.xmlnamespace.panel.lib.communication.request.manager.RequestTopicManager.handleMessage(
	at com.xmlnamespace.panel.lib.communication.jms.JMSTopicConnection.onMessage(
	at org.apache.activemq.ActiveMQMessageConsumer.dispatch(
	at org.apache.activemq.ActiveMQSessionExecutor.dispatch(
	at org.apache.activemq.ActiveMQSessionExecutor.iterate(
	at org.apache.activemq.thread.PooledTaskRunner.runTask(
	at org.apache.activemq.thread.PooledTaskRunner$
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$ Source)
	at Source)

This is what iSymphony team answered me:

iSymphony does not
currently support Asterisk 12 or 13. Take a look at the following
document for our currently supported platforms:

It is not known at this time when Asterisk 12 and 13 support will be available, but it is one of our top priorities.

Michael Yara
i9 Technologies

I quit using it a long time ago, for me it is too bulky, too hard to use and understand. We used to have FOP2, it worked great but FreePBX took the route of the super expensive iSymphony. I don’t use either anymore, FOP2 worked fantastic up to the point of it being dropped from the project. Might work, I have not tried to install it and don’t even know if it works on later versions of FreePBX. Maybe worth a try if you don’t want to use iSymphony.

This is an old post so apologies for re-opening it.

I have been working with iSymphony in Asterisk 13 / FPBX 12 now for a couple of days and having the same problems. As per instructions from iSymphony Sales I am using the iSymphony 3.2 beta, which supports Asterisk 12 and 13. All PJSIP endpoints.

I am now dealing with Michael Yara to resolve both the lack of Extension Status’s and now, the inability to originate a call.

Some of the troubleshooting we’ve done was to ensure that the Peer details for Extensions/Users are in fact coming across as PJSIP/222 instead of SIP/222 (known bug). We checked that the cxpanel manager user had appropriate permissions (which it didn’t) and that it was connecting to Asterisk (which it was).

So far I haven’t gotten it to work.

I’ve used iSymphony before with Asterisk 11 and was quite impressed, it by far outshone other offerings in terms of ease of use and configuration.

Please keep updating this thread, I just purchased licenses not knowing this was an issue. I am using Asterisk 13 with PJSIP and I don’t want to go back. What permissions did you need to give cxpanel and where? Also, how do I get that beta? Thank you

3.2.1 is stable now.
if you purchased Isymphony licence, please contact
they are really helpful guys.