Trunks will not register under astersik 1.8.7

I have several trunks with the local carrier which work fine on a different asterisk server running asterisk 1.4.22 but will not register with my new Elastix server I keep getting Forbidden from the carrier

Here is the trunk setting in free PBX


With the registration string of:
[email protected]:[email protected]/USERID

as mentioned in the this link since asterisk 1.6
the register string should be the domain should be root zone.
in the debug asterisk seems to strips the the diagest username and only sends since its not root zone.

Here is debugs from asterisk 1.4 and asterisk 1.8 with the same register string

This is for FreePBX running Asterisk 1.4.22

User-Agent: FPBX-2.9.0(1.4.22)
Max-Forwards: 70
Authorization: Digest username="[email protected]", realm="", ...

And This is for FreePBX running Asterisk

User-Agent: FPBX-2.8.1( Authorization: Digest username="USERID", realm="",.....

Any help will be appreciated

Make your trunk name USERID and your context from-trunk. The context you are using is the catch all that requires anonymous sip to be turned on in the general settings.

Sorry, ignore what I said, I have re-read your post and I don’t think this is the problem.

anyone ???


in 1.6 and above you need to define a separate section which you can then use in the register string …

that was no hel it did not resolve the issue we tried with a single quote and double quote

Try making the first part of the registration string userid without the at etc. I have trunks registering fine to three different providers with latest update to the distro using just the userid.

we tried with a single quote and double quote
huh ? where did you get that ? :wink: