Trunk Unavailable

Does anyone have an issue where their trunk is unavailable after a reboot?

I use IP Authentication with my SIP provider. Sometimes (but not always) after a reboot, the status of the Trunk says unavailable. When it is in this state, people can’t call out. Issuing a command of “pjsip qualify TRUNK” instantly brings the trunk online. This just recently started happening to me. Is there any reason this would be happening? Is there a way to ensure the trunk comes online after a reboot?

Endpoint: TRUNK Unavailable 0 of inf

does your trunk have qualify=yes set on it?

also… how often are you rebooting your pbx? for how rarely it Should be rebooted, is the ~30 seconds for a trunk to qualify itself a major issue?

I don’t have that exact value. I use FPBX15. I only see the option for “qualify frequency” and that is set to 60. seconds.

I reboot once a week.

full platform reboot?

you might want to look at scheduling / Cron Jobbing something more like:

#! /bin/bash
/usr/sbin/asterisk -rx "core restart when convenient"

the full hardware likely Shouldnt be rebooted that often, but i can understand kicking Asterisk

That might be a better option.

However, this never used to happen on my FPBX13 server. Should I be changing something with the qualify frequency?

is your trunk sip or pjsip?


sip trunk (in the browser):
Edit trunk > sip settings > outgoing > peer details section
add qualify=yes if its not there already

not seeing it… it might just automatically do it.

after a reboot, while its broken, you should run sngrep and check for a sip Options message going out.
and see if the far end is responding to it.
im curious to see if your pbx is NOT sending the sip options (qualify), or if the far end is not responding.

with your qualify frequency set to 60, i would expect your trunk to be down for a minute or two, then recover itself after a reboot (once freepbx is up and running, of course)

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.