Trunk to CISCO

Good Afternoon Colleagues
I hope you are doing good and safe.

I have successfully configure trunk between FreePBX and CISCO 2801 router (equipped with FXO ports) . I configured inbound route so all calls received from CISCO gateway destined to the Queue.

Everything worked as expected and inbound calls directed successfully to Queue.

The issue that when i go to Reports ==> Astersik Info , The status of the trunk to CISCO is showed as offline inspite the fact the trunk is working as expected and calls received through it successfully. Also when a call received through the trunk and in spite the status showed as offline , Channel Count has value 1.

Do you have any idea for the reason of this issue and how can i solve it?

Best Regards

Which channel driver are you using?

How is the trunk configured, especially with regard to registration, qualify and authentication?

You might want to note that incoming calls will be accepted from unregistered peers and qualify failures will not prevent incoming calls.

Good Morning David
Thanks for your replay . Below are my configuration .

Best Regards

I’ve only used Cisco trunks with IP matching and authentication. Are you sure that the Cisco is actually trying to register with you? I’d expect you to already know its address.

Hello David

  • Can you share with me the configuration you used?
  • As i shared , Calls received to FreePBX through CISCO.

Best Regards

It was half a decade ago. It was for chan_sip. And it was raw Asterisk. The Asterisk end was basically just host=xxxx; type=peer; context=yyyy; disallow=all; allow=allaw. I can’t remember the details of the Cisco end. I didn’t set that up originally and I had to look at the documentation when I had to work on it.

Hi David
Well noted and thanks for trying to help.

Best Regards

If it didn’t have
then Asterisk was not accepting registration, so try setting Registration to None in your pjsip trunk.

Hi David
It worked when registration set to none !

It is now show as online.

Thanks for your help & support.

Best Regards

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.