Trunk sip infostrafa


(Peppe3895) #1

Salve a tutti ho un problema con la registrazione del trunk di infostrada su freepbx.
Uso un raspberry dive freepbx supporta sia sip che pjsip il problema è che se lascio di default la porta in chan sip 5160 il trunk si registra mentre se cambio la porta a 5060 il trunk mi va in errore .ora volevo sapere quale potrebbe essere il problema,inoltre anche se il trunk si registra con la.porta 5160 non riesco ne ad effettuare ne a ricevere chiamate


(Danilo Smaldone) #2

ciao @Peppe3895
Il problema che stai riportando mi fa pensare ad un noto problema con il SIP ALG di molti modem
Hai provato a disattivarlo?


(Peppe3895) #3

ciao no non ho provato a vedere come router ho un fritzbox però sul fritz box già ho disattivato la numerazione voip cosa altro devo controllare?


(Danilo Smaldone) #4

Sul FritzBox ( a parte che ci sono vari modelli, quindi il mio consiglio è i inviare sempre più informazioni possibili - Marca/Modello/Firmware etc) mi risulta non sia possibile disattivare il SIP ALG.

Proprio perchè ha a bordo un client SIP, ci possono essere “interferenze” del software base con la tua configurazione. La soluzione suggerita è spostare tutto su porta 5160 e attivare un port Forward.

Ci tengo a precisare che questo post non riguarda FreePBX ma SIP in genere


(Peppe3895) #5

fritzbox 4690 …farò questa prova e ti farò sapere


(Peppe3895) #6

ho resettato completamente la memory card e riconfigurato da capo ora il trunk è registrato le chiamate in arrivo funzionano mentre quelle in uscita no ho provveduto anche a dichiarare outbound cid nell’interno in uso (200) ma non va


(Danilo Smaldone) #7

C’è bisogno di qualche dato in più, non siamo indovini, siamo tecnici. Qualche log di asterisk riferito alle chiamate, la versione in uso di asterisk e di FreePBX la configurazione dei trunk (senza user/pwd), se si usa Chan SIP o PJSIP…insomma se vuoi essere aiutato nella diagnostica, servono informazioni precise sul problema


(Peppe3895) #8

sono riuscito a sistemare le chiamate sia in entrate che in uscita il problema era che il pbx era collegato al mikrotik ke a sua volta era collegato al router principale .Ora l’ho collegato direttamente al router principale e funzione ma ho solo 1 problema che se da locale chiamo 1 interno configurato su 1 cellulare con zoiper la chiamata arriva ma è muta.Preciso che ho gia provveduto ad aprire le porte da 10000 a 20000 verso il freepbx ma non ho avuto esiti positivi …cosa potrei verificare ???


(Danilo Smaldone) #9

Come vedi @Peppe3895 mancavano tante informazioni. Il mikrotik fra il PBX e il router sicuramente ha aggiunto un’altra NAT e in più ha a bordo il SIP ALG.
Comunque al momento la situazione dovrebbe essere

INTERNET <–>MODEM XDSL<–>FreePBX

Come hai impostato il trunk? PJSIP o Chan SIP? Purtroppo senza i dettagli/log è impossibile aiutarti di più


(Peppe3895) #10

il trunk è impostato su Sip e anche gli interni sono imposati su sip con 1 regola di portforwording dove dall’esterno la porta 5060 viene girata alla 5160 interna …questo è errore che mi da quando si chaima 1 interno locale e 1 remoto :


(Danilo Smaldone) #11

Ok @Peppe3895 questo problema avviene quando la NAT non si comporta in modo corretto. Assicurati di aver impostato la NAT correttamente:
General SIP Settings

  • External Address: il tuo IP Pubblico
  • Local NetWorks: la tua LAN (e.g. 192.168.0.0 / 24)
    Media Trasport Settings:
  • STUN Server: usa ad es google (stun4.l.google.com:19302)
    ICE Host Candidates:
  • IP del tuo PBX => il tuo IP Pubblico

In Chan SIP Settings
NAT: yes
IP Configuration: Static IP
Override External IP: il tuo IP Pubblico

In tutta onestà queste impostazioni funzionano nella maggior parte dei casi, ma a me pare dal log che il forward che hai messo in piedi non funziona correttamente. In più sarebbe interessante capire la configurazione del Trunk
Ciao


(Peppe3895) #12

ecco a te le varie configurazioni :


(Danilo Smaldone) #13

@Peppe3895 partiamo da un punto fondamentale. Per la tua configurazione, usando Chan_SIP ti server settare soltanto la parte Outgoing del Trunk e la register string dell’Incoming. User Context e Details dell’Incoming lasciali Vuoti.
Veniamo a noi:

Usiamo il numero 02/12345678 come esempio

Outgoing: 0212345678 (Trunk Name è comodo inserire il solo numero)
User Details:
type=peer
callerid=390212345678
username=390212345678@sip.infostrada.it
secret=INSERIRE_LA_PASSWORD
fromuser=390212345678
fromdomain=sip.infostrada.it
host=sip.infostrada.it
outboundproxy=voip.libero.it ( oppure 151.6.93.166)
insecure=port,invite
realm=sip.infostrada.it
port=5060
nat=yes
qualify=yes
regseconds=60
disallow=all
allow=alaw
allow=ulaw
allow=g729

Per ciò che riguarda la parte incoming
Register String: 390212345678:INSERIRE_LA_PASSWORD@sip.infostrada.it/390212345678

oppure

Register String: 390212345678@sip.infostrada.it:INSERIRE_LA_PASSWORD@sip.infostrada.it/390212345678

Dipende dal server dove vai ad autenticarti.

Ho letto che voip.libero.it non viene risolto se si chiama al di fuori della rete infostrada, per cui se non sei su coinnettività infostrada ci possono essere diversi tipi di problema.

Spero di averti dato un aiuto concreto


(system) closed #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.