Trunk SIP - Error connection because outbound proxy ? or hostname?

Hello everyone, my problem persist since 5 weeks.

I success to connect my FreePbx with OVH, but we changed the SIP providers.
Now, its Orange, and SIP Trunk dont even work WITH FreePBX.

BUT it works with 3CX Softphone, its strange.


There is abolutely no probleme, i can call with the softphone.

Now, for my FreePBX config →

I made a misstake in the conf ?

Please, i need you help, i lost ! Thanks for all !

Chan_sip is deprecated, if you’re setting up new trunks today you need to be using PJSIP.

Ok, but, can i communicate with Chan_SIP in internal, and use ChanPJSIP for trunk, is it possible ?
Sorry, im not a professional

Yes, you can mix and match drivers if you want. Remember that each will use a different bind port and you must be careful which driver uses which port when setting up registrations.

Ok thanks, i will try it but, i think this will not fix my error

Atm i have this error, i did PJSIP Trunk

You’d have to ask Orange why they are returning 500 Internal Server Error.

I did but Orange wont help me, because its Asterisk :smiling_face_with_tear:

Try these pjsip trunk settings, based on my very limited experience with 3CX. If you have trouble, at the Asterisk command prompt, type
pjsip set logger on
make or receive a failing call, paste the Asterisk log for the call at and post the link here. If the trunk won’t register, paste the log of a registration attempt.

Also, paste a SIP trace from 3CX, showing the same function (registration, incoming or outgoing) that is not working in FreePBX

Username: +331648XXXXX
Auth username: (same as ID in 3CX)
Secret: (your SIP password)
SIP Server:
Outbound Proxy:\;lr\;hide
From Domain:
From User: +331648XXXXX

OK thanks a lot, you save me, it was mistake i didnt put the From Domain and From user.

Now i have voice, only in one side, how can fix this ?

Ok its was just my headphone, it work perfectly btw ! Thanks you so much @Stewart1

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.